Go Down

Topic: Alle prime armi (Read 523 times) previous topic - next topic

binko


Ho acquistato ieri una scheda Arduino/Genuino Uno, con cavo USB lungo circa 1,50 cm.
Ho scaricato l'app Windows Arduino IDE e ho collegato la scheda (ho Win 10)
All'inizio è andato tutto liscio, nell'IDE ho selezionato la scheda e la porta (COM3) e caricato uno degli esempi (blink).
Dopodichè, ho provato un altro esempio e non caricava sulla scheda. Ho controllato le porte ma l'icona di selezione della porta era disattivata, quindi non caricava niente.
Mi chiedo se è forse un problema di USB e chiedo a voi di illuminarmi sul problema...
Grazie

gpb01

Buonasera,
essendo il tuo primo post, nel rispetto del regolamento della sezione Italiana del forum (… punto 13, primo capoverso), ti chiedo cortesemente di presentarti IN QUESTO THREAD (spiegando bene quali conoscenze hai di elettronica e di programmazione ... possibilmente evitando di scrivere solo una riga di saluto) e di leggere con MOLTA attenzione il su citato REGOLAMENTO ... Grazie. :)

Guglielmo

P.S.: Qui una serie di link utili, NON necessariamente inerenti alla tua domanda:
- serie di schede by xxxPighi per i collegamenti elettronici vari: ABC - Arduino Basic Connections
- pinout delle varie schede by xxxPighi: Pinout
- link generali utili: Link Utili
Search is Your friend ... or I am Your enemy !

gpb01

Hai già provato a cambiare cavo USB? .... ultimamente abbiamo assistito ad una moria di detti cavi ::)

Guglielmo
Search is Your friend ... or I am Your enemy !

ORSO2001

definire cavo qualche cosa lunga 1,5 cm (compresi i connettori ?) mi sembra troppo entusiastico...scusate non ho resistito... :D

binko

non so che mestiere lei faccia ma non mi venivano altri termini

ORSO2001

ciao binko...devi scusarmi...è che avevi scritto 1,50 cm, che io leggo "uno virgola cinque centimetri"...un po' corto come cavo USB...forse intendevi 15 cm (quindici centimetri)...o forse 150 cm (centocinquanta centimetri).
Comunque come dice Guglielmo ultimamente qui nel forum sono stati confermati diversi casi con cavi USB difettosi...provane uno di cui sei sicuro e facci sapere.

scusami ancora...volevo solo "sdrammatizzare"...

P.S.: se vuoi dammi del "tu" che per me va benissimo

Patrick_M

aggiungo

occhio che per cavo USB di cui sei sicuro NON vanno bene quelli per esclusivamente fatti per caricare i cellulari
per inserire (lo sketch) il programma, dall'IDE clicca modifica, clicca copia per il forum poi vieni qui e incolla nel tuo post (ctrl+v) ;)

docdoc

occhio che per cavo USB di cui sei sicuro NON vanno bene quelli per esclusivamente fatti per caricare i cellulari
Vero (quelli hanno solo 2 conduttori invece di 4), ma ha detto di aver acquistato la scheda che comprendeva il cavo, quindi credo sia quello corretto.

Gli direi comunque di provare a cambiare porta per iniziare. Poi se è un Arduino non originale, verificare l'installazione dei driver USB specifici per il chip seriale della scheda.
In base all'esito di queste prove direi si possa proseguire.
Alex "docdoc" - ** se ti sono stato d'aiuto, un punto karma sarà gradito, clicca su "add" qui a sinistra, vicino al mio nome ;) **

gpb01

#8
Jul 12, 2018, 10:53 am Last Edit: Jul 12, 2018, 10:53 am by gpb01
... più che altro ha detto:

... All'inizio è andato tutto liscio, nell'IDE ho selezionato la scheda e la porta (COM3) e caricato uno degli esempi (blink).
Dopodichè, ho provato un altro esempio e non caricava sulla scheda. Ho controllato le porte ma l'icona di selezione della porta era disattivata, quindi non caricava niente. ...
... quindi, inizialmente, il tutto funzionava e vedeva una COM3:, poi tutto è sparito ::)

Guglielmo
Search is Your friend ... or I am Your enemy !

Patrick_M

Vero (quelli hanno solo 2 conduttori invece di 4), ma ha detto di aver acquistato la scheda che comprendeva il cavo, quindi credo sia quello corretto.

...omissis

si proprio per questo dicevo, quello comperato con l'arduino (possibile clone) può essere di pessima qualità attaccato per miracolo e dopo un primo utilizzo....;)
per inserire (lo sketch) il programma, dall'IDE clicca modifica, clicca copia per il forum poi vieni qui e incolla nel tuo post (ctrl+v) ;)

Etemenanki

#10
Jul 12, 2018, 06:05 pm Last Edit: Jul 12, 2018, 06:06 pm by Etemenanki
Ultimamente c'e' la mania dei cavi comperati su internet o dai Cinesi a prezzi indecenti ( tipo 50 centesimi per due metri di cavo usb ... neppure la plastica ci comperi) ... poi quando me li portano che non vanno piu e gli dimostro cosa c'e' dentro, si ricredono ... fili AWG32 o peggio (a volte talmente sottili che se tiri il cavo, l'isolante si allunga leggermente ed il filo di rame si spezza, da fuori non te ne accorgi pero' e' da buttare), conduttori singoli invece della schermatura (fra l'altro da 0.25mm), rame preossidato (nel senso che quando togli l'isolante, il poco rame che c'e' e' nero) ... per forza poi smettono di funzionare ...

E quelli che vendono "glod plated" non sono meglio ... mi hanno portato un paio di cavetti "audio" (audiotruffa, dico io), con i jack ed i cinch "placcati oro" tutti ossidati e mezzi neri ... dato che l'oro, com'e' noto, NON si ossida, sarebbe interessante sapere cosa esattamente spacciano per "oro" :D :D :D

E la cosa peggior e' che ultimamente anche alcune ditte "serie" (o presunte tali) ci sono cascate, ed i cavi che forniscono in dotazione fanno letteralmente schifo :D
"Sopravvivere" e' attualmente l'unico lusso che la maggior parte dei Cittadini italiani,
sia pure a costo di enormi sacrifici, riesce ancora a permettersi.

binko

per ORSO2001: ho riso quando ho letto la tua battuta, in effetti la meraviglia è lecita per un "cavo" da 1,50 centimetri! In effetti ho sbagliato e volevo scrivere 150 centimetri.

Il cavo NON è stato comprato con la scheda Arduino, neanche dallo stesso rivenditore. E' un cavo che ho pagato sette euro in un Internet point gestito da bangladini. Con ciò non intendo dubitare dei signori bangla, sono ottime persone, e comunque è possibile che delle forniture se ne occupi un italiano.

Domani provo a tornare dal rivenditore e acquistare un cavo da lui. Sono riuscito a selezionare la porta seriale (è apparsa) dopo aver ripetutamente attaccato e staccato il cavo dalla scheda. Ho caricato blink, ha eseguito, poi la porta è scomparsa nuovamente.

gpb01

#12
Jul 12, 2018, 09:59 pm Last Edit: Jul 12, 2018, 09:59 pm by gpb01
... Sono riuscito a selezionare la porta seriale (è apparsa) dopo aver ripetutamente attaccato e staccato il cavo dalla scheda. ...
Probabile filo interrotto che fa e non fa contatto ::)

Guglielmo
Search is Your friend ... or I am Your enemy !

docdoc

(a volte talmente sottili che se tiri il cavo, l'isolante si allunga leggermente ed il filo di rame si spezza
Beh questo però, diciamolo, capita anche con i costosissimi cavi iPhone.... ;)

E' un cavo che ho pagato sette euro in un Internet point gestito da bangladini.
Domani provo a tornare dal rivenditore e acquistare un cavo da lui. Sono riuscito a selezionare la porta seriale (è apparsa) dopo aver ripetutamente attaccato e staccato il cavo dalla scheda. Ho caricato blink, ha eseguito, poi la porta è scomparsa nuovamente.
E tutto ciò cosa ti suggerisce? ;)
Alex "docdoc" - ** se ti sono stato d'aiuto, un punto karma sarà gradito, clicca su "add" qui a sinistra, vicino al mio nome ;) **

Go Up