Go Down

Topic: IDE freezes during Start (Read 162 times) previous topic - next topic

rasputinbkz

Hi

I am facing issues trying to run the latest IDE. I am on a linux mint 64 and the IDE is 1.8.5. When it starts, I get, installing packages; preparing cards and Starting. It stays forever in this state, I need to kill the java application to close it...

Any clues?

pert

Run the Arduino IDE from the command line and then post the output here using code tags (</> button on the toolbar).

rasputinbkz

Hi

Thanks for replying...

bd@Berkovitz ~/Téléchargements/arduino-1.8.5 $ ./arduino
Picked up JAVA_TOOL_OPTIONS:
./arduino : ligne 35 :  4380 Processus arrêté      "$JAVA" "${JAVA_OPTIONS
  • }" processing.app.Base "$@"


After the second line, I killed the java process as it was not going anywhere.... Seems like a java issue right?

Need to install later version or something like that?

pert

I'm not very experienced with Arduino IDE on Linux (I do use it on my Raspberry Pi but haven't had any problems). My understanding is that the official version of the Arduino IDE from http://www.arduino.cc/en/Main/Software comes with a JVM bundled so that they don't have any problems of incompatibility between the Arduino IDE and whatever version of Java the user has already installed on their computer. So that would make me think that the problem is not related to which Java you have installed.

Maybe someone else here will be able to provide an answer based on the new information you provided.

Go Up