Go Down

Topic: [Resolved] pb with arduino uno and debian squeeze (Read 2859 times) previous topic - next topic


Mar 19, 2011, 02:46 pm Last Edit: Mar 20, 2011, 03:09 pm by willtynux Reason: 1
i'm a fresh french user of arduino. I install a debian squeeze on my pc (to replace an ubuntu).
i connect the board to usb, i run IDE but i can't select  the serial port (with ubuntu it worked).

Someone can help me ??


Which Arduino board are you using?  Does it appear in /dev/?  Do you have anything in the Tools > Serial Port menu?  Which version of the IDE?


Which Arduino board are you using?  Does it appear in /dev/?  Do you have anything in the Tools > Serial Port menu?  Which version of the IDE?

- Arduino Uno
- I can't select serial port (grey)
- IDE 018 and 022
- How can i see it in /dev/ ?


Try "dmesg" or "ls /dev/tty*".  You probably have a /dev/ttyACM0 when the Arduino is connected.  The version of RXTX (the serial library that the Arduino software uses to communicate with the board) that comes with your distribution probably doesn't know how to find those devices.  Try symlinking /dev/ttyACM0 to /dev/ttyUSB0.  Or try downloading the Arduino software from the download page rather than installing it from your distribution's repository.  (It has a version of RXTX that looks for /dev/ttyACM devices.)  Or try upgrading RXTX.


I find a ttyACM0 with "dmesg" an "ls /dev/tty*".
I tried the last version of IDE (022) from the download page and it doesn't work.
How can i symlink /dev/ttyACM0 to /dev/ttyUSB0 ??


ok i found how to solve my pb :
- user has to make party of the group "dialout"
Code: [Select]
sudo usermod -a -G dialout user_name (thanx to Louis-Maurice !)

- download IDE from the website (v. 022) and run it
- select ttyACM0 serial port
- have fun !

Don't use the IDE version (018) that debian porpose, that doesn't work.

Thank you melis and Louis-Maurice  :D


i made a reportbug and there is some news :

From Scott Howard :

o use with an UNO, you need to use the librxtx-java package 2.2pre2-3
or newer. The Uno uses a new usb to serial chip, and needs the the
updated rxtx. You can download it from
http://packages.debian.org/sid/librxtx-java, pick your architecture
from the bottom then dpkg -i {the downloaded.deb}.

You also need to update your arduino packages to at least 0022-1 since
Uno support is only in 0022-1 and newer. The Uno was released after
squeeze was frozen, so you have to use the packages in wheezy/unstable
or download them from packages.debian.org/arduino.

See the changelog for RXTX:

rxtx (2.2pre2-3) experimental; urgency=low

   * Added ${java:Recommends} to debian/control to recommend links to
     system installed javadocs per Debian Java Policy.
   * Debian policy 3.9.1 (no changes).
   * Added ttyACM_ports.patch to allow for enumeration of many additional
     ports, including ttyACM used in Arduino Uno development boards.

I made this and it's working well !

Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131