Go Down

Topic: Voltaje negativo en led  (Read 119 times) previous topic - next topic

hypernovat

Jul 19, 2018, 09:41 pm Last Edit: Jul 19, 2018, 09:53 pm by hypernovat
Hola,  adjunto una foto de un modulo matriz led 8x8 con el integrado max7219 y sin el array de leds. Como se ve tiene conectado un led que esta encendido luego de cargar el soft correspondiente al arduino (en vez de encender un pixel del array hago lo propio con este led).
La pata derecha es el catodo del led sin embargo al colocar las puntas del multimetro, negativo en dicha pata y positivo en la otra la marca es de -4.90V, diculpen mi ignorancia se que esto es electronica pura mas alla del Arduino, pero ¿como se explica esto?
Gracias.

surbyte

Dificilmente tengas una tensión como la que te imaginas porque el MAX7219 maneja los leds del array de manera multiplexada (acabo de leer el datasheet y lo hace a 800Khz). Asi que sinceramente no se que estas leyendo.

Tendrias que poner un osciloscopio y capturar lo que reciben esos dos pines y verías una señal cuadrada de ancho de pulso mas bien corto.


hypernovat

Gracias surbyte por la respuesta, lo que es seguro es lo que mido y que las patas del led estan al revez de la logica posicion de un led, tal vez el multimetro no sea el instrumento para medir lo que sucede como sugieres, pero como imaginas no tengo un osciloscopio. Saludos.

(mañana voy a medir los ampers y ver que sucede alli no tanto por la cantidad, fijate que no uso resistencia, sino para ver si hay coherencia con el signo que me marco la tension medida)

hypernovat

#3
Jul 20, 2018, 05:54 pm Last Edit: Jul 21, 2018, 06:32 am by surbyte
Bueno, el multimetro se desmiente asi mismo, para la medicion de la corriente que circula me marca como es de esperar. La situacion la resumo en este dibujo. Saludos.

Aqui


Go Up