Go Down

Topic: No Reconoce puertos ni con Drivers. (Read 218 times) previous topic - next topic

ElectroRev

Buena tarde a todos, hace algunos días me compre un Arduino UNO ( Original) Claro como en este PC no he instalado ningún driver, ( Para ningún tipo de embebido) Era lógico que me apareciese  un error al no detectar los puertos ( COM).
En ese primer error tenia instalado el Arduino  Zip donde los drivers  eran necesarios instalarlos manualmente lo hice y no detecto puertos, busque un poco por la pagina y instale un .exe el que al instalarlo me instalaba los drivers automáticamente... Tampoco sirvió ( obviamente realice la instalación de los drives  en ambos casos por administración de dispositivos ) tampoco me sirvio entonces busque por Youtube donde descargue un programa para generarme esos drives lo cual tampoco sirvió. Asi que quisiera saber de que manera puedo hacer que me funcione, leí un poco y quizá se pueda hacer  abriendo un puerto especifico por FireWall.

Esfinterman

Hola!! Al decir que has bajado un EXE intuyo que estás trabajando con Windows. Mi experiencia con Arduino y Windows es escasa, no dándome prácticamente fallo alguno pero también es cierto que de 200 veces que arranco Arduino, una lo arranco en Windows. ;)

Si la placa es original y es una R3, estará basada en el chip ATMEL. En Mac y Linux no hace falta instalar controlador alguno. Si la placa es FTDI, ES POSIBLE que necesites instalar el controlador. Por último, si la placa lleva el CH340 tienes que instalar controlador sí o sí.

Si estás en Windows, en cualquier caso te toca instalar el controlador. No recuerdo muy bien cómo lo hice, ya que en ese PC solo he usado un Arduino LEONARDO y un DUE. Y no recuerdo que para el DUE me pidiese controladores, imagino, que por haber instalado con anterioridad la LEONARDO.

En Windows, cuando conectas la placa y no has instalado el controlador, te va a pedir instalarlo. El controlador está dentro de la carpeta del programa de Arduino, en alguna ruta en concreto. No te lo puedo decir ahora porque estoy en Mac, pero está dentro de Archivos de Programa/Arduino. Ese es el controlador oficial para la placa. Si no te deja instalarlo de nuevo tienes dos opciones:

-Conecta la placa en otro puerto, si instala el controlador automáticamente...
-Desinstala el controlador o actualiza el controlador desde el administrador de dispositivos. Al actualizarlo, selecciona la ruta del IDE de Arduino, la carpeta que corresponda. Debe funcionar.

En cuanto al cortafuegos, para estar tranquilo, quítale el cable de internet a la máquina/desactiva la red inalámbrica y quítalo. Instala de nuevo, pero no creo que el problema venga de ahí.

Si esto no funciona, no puedo ofrecerte más ayuda, ya que prácticamente no uso Arduino en Windows, y cuando lo hago es testimonial. No ayuda tampoco que no haya tenido problemas al instalarlo. ;)

surbyte

Cuando instalas el IDE de arduino que no has dicho que versión has instalado ya se instalan los drivers para los Arduinos ORIGINALES. Los que usan CH34X no se instalan aún, como tampoco otros microcontroladores que funcionan programando estilo Arduino pero no lo son.

Intenta dar algun detalle de:
que Sistema Operativo usas aunque concuerdo que es Windows pero dinos la versión.

Que IDE has instalado.
Has desinstaldo algo
Especificamente que .zip o .exe has instalado y de donde lo has descargado.

NOTA: el foro tiene normas y los enlaces se deben postear usando etiquetas. Lee las normas y observa si no entiendes en otros hilos como se hace pero las normas estan claramente explicadas.

Si te equivocas puedes editar luego de 5min de posteado. Pero antes de postear mira todo usando PREVIEW y con eso te aseguras que se vea bien.

Go Up