Go Down

Topic: RESOLVED -Burn Bootloader Not Working (Read 221 times) previous topic - next topic

mikagrubinen

Jul 23, 2018, 10:20 pm Last Edit: Jul 23, 2018, 10:56 pm by mikagrubinen
Hi,

I am on Windows 10 and using Arduino IDE 1.8.5. I have Arduino Zero board and everything was working ok until...

I wanted to use Atmel Studio, so I made simple blinky code
by going to:
- File | New | Project
- GCC C Executable Project, not "Create Project from Arduino Sketch"
- chose ATSAMD21G18A

and uploaded to board over programming port on Zero. Since I knew it will delete bootloader I already read how to restore it.

Open Arduino IDE, go to tools,
Select Board: Arduino/Genuino Zero (Programming Port)
Programmer: Atmel EDGB
and then to "Burn Bootloader",
but I am getting an error:

Code: [Select]

Arduino: 1.8.5 (Windows 10), Board: "Arduino/Genuino Zero (Programming Port)"

Open On-Chip Debugger 0.9.0-g932ec70 (2017-02-15-12:34)
Licensed under GNU GPL v2
For bug reports, read
 http://openocd.org/doc/doxygen/bugs.html
debug_level: 0
adapter speed: 500 kHz
adapter_nsrst_delay: 100
cortex_m reset_config sysresetreq
Error: unable to open CMSIS-DAP device 0x3eb:0x2157

Error while burning bootloader.


I tried few solutions but none of them worked. Can anyone help with some ideas?

Thanks

EDIT: IT just started working, not sure why and how.

Go Up