Go Down

Topic: Implementation for Microchip ENC28J60 Ethernet controller (Read 35 times) previous topic - next topic

alvarojusten


I tried WebServerSimple and it worked. I can ping my board and access it from a browser.
But only for a while. After that I get the connection lost. No more ping or browser access.

Do you have any idea. I've been struggling for 3 days and nothing.


Hello Inacio,
did you do any modifications in WebServerSimple example? Please try to use a lighty HTTP client such as wget and curl, do a lot of subsequent requests (without concurrency) and tell me if the sketch stopped to work (if yes, with how many requests using wget/curl).
Blog pt_BR: http://blog.justen.eng.br/
Curso de Arduino (Arduino Course, in Brazil) - http://www.CursoDeArduino.com.br/

Splatter

Thanks for working on this.  I'm sure it will be a big help to the community.   

I recently purchased one of the eBay EtherShields with the intention of using it in conjunction with the iPhone app Ardumote (which uses only UDP messaging), but once I started digging around trying to code anything using the supplied ENC28J60 library I realized it wasn't worth the effort and ordered an Arduino W5100 Ethernet Shield.  With your efforts however, I'm sure I will find a use for my ENC28J60 based shield one day and many others will benefit from the lower cost ethersheild!


mmoz

Has anyone experience with this library and the nanode ? (http://wiki.hackspace.org.uk/wiki/Project:Nanode)

I tried to edit the file enc28j60.c as follows : #define ENC28J60_CONTROL_CS     8
without any success.

mem

it would be easier to help if you said what the error was.

did you change also change the following?
   #define SPI_SS      8

did the sketch compile and run with the default CS/SS pin?

mmoz

The sketch uploads without any problem.
What happens is that the board does not respond to either a ping or a http request, even after modification of the SPI_SS constant.

Go Up