Go Down

Topic: Ayuda max232 (Read 2914 times) previous topic - next topic

chato_sat

Mar 22, 2011, 01:48 pm Last Edit: Mar 22, 2011, 02:41 pm by chato_sat Reason: 1
Hola a todos, estoy intentando conectar arduino a un modem gsm (mtx65i). Necesito conectarlo a través de rs232 y para ello estoy intentando utilizar un max232n(datasheet: http://focus.ti.com/lit/ds/symlink/max232.pdf), pero no consigo nada. He leído varios hilos que tratan sobre el tema y como casi todos están en inglés no sé si se me habrá pasado algo por alto. Las conexiones que he realizado son las siguientes:



También he conectado en el db9 los pines 1, 4 y 6 entre sí y el 7 y 8 también entre sí. Pero nada. Sólo me he dado cuenta que si no enganchas el db9 al max232 y mides el voltaje entre los pines 13 y 14 este fluctúa como si se estuviera escribiendo, pero si conecto el db9 entonces el voltaje es 0 sin fluctuaciones, esto me pasa aunque el db9 no esté conectado al pc (no sé si esto será normal)

SOLUCIONADO: He medido y existía continuidad entre los 3 cables (gnd, tx y rx) del db9, he cambiado el cable y voilá ya funciona perfectamente.

Es absolutamente necesario los puentes entre los pines 1, 4 y 6 y 7 y 8 del db9??

Se aceptan sugerencias.

Gracias

flico

Quote
Es absolutamente necesario los puentes entre los pines 1, 4 y 6 y 7 y 8 del db9??


No es necesario

salu2

chato_sat



No es necesario



Y para que sirven?? Añaden algún tipo de control de flujo o algo??

Gracias

chiva

Al revés, sirve para "quitar" el control de flujo, es para hacer lo que se llama un cable null-modem

Go Up