Go Down

Topic: arduino IDE slow to start up - has anyone found turning off AntiVirus fixes it? (Read 798 times) previous topic - next topic

robert rozee

hi,
    have found that with Panda Cloud AntiVirus software running, the arduino IDE is extremely slow to start up and produces a 'Launch 4J' error message (though still does eventually run). the behaviour is almost identical to that reported with bluetooth devices present. this was running on a netbook under winXP.


has anyone else found that TURNING OFF ANTI-VIRUS SOFTWARE fixes problems with the arduino IDE?


cheers,
rob   :-)

MarkT

Its not an ideal solution though is it?  I can imagine loading all the libraries at start up is causing the AV software to do lots of redundant checking if its not optimized.

Since I'm on Ubuntu I never have such problems 8)
[ I won't respond to messages, use the forum please ]

robert rozee

"Its not an ideal solution though is it?":
one can argue that breathing is not an ideal solution, yet it is somewhat necessary if one wants to carry on living   ;)

turning OFF my anti-virus software is the only solution i have found to allow the IDE to start up correctly. and the fact that it DOES work is indicative of where to investigate the underlying defect in the IDE's operation - assuming that a "launch 4J" error message is classified as a defect.

i am interested in seeing if turning OFF their anti-virus software solves startup delay issues for those using other anti-virus software (norton, AVG, etc), as the startup delays seem to be a widely encountered issue that the developers of the arduino IDE have largely relegated to the 'too hard' basket.

CKoch

i am also using panda cloud antivirus on my laptop (old one, i use with the arduino software) and it's running ok .... maybe a little slow but it's running.
the 'launch 4j' error appears from time to time when i try to load the arduino software with the laptop not fully booted (klicking too fast). i assume it is somewhat related to the enviromental setting (path to the jre not set properly at that point). so you should check your %path% variable.

robert rozee

any chance you could carry out a few experiments for me?

1. using a stopwatch, time how long it takes between clicking the icon to launch the IDE and the edit window appearing with Panda AV running.
2. repeat, but with Panda AVI disabled (right-click panda icon in system tray and select 'Stop antivirus')
3. observe CPU usage during the above two tests, just using Windows Task manager to get a bit of an estimate is fine. If you can, perhaps try and see what process is using most CPU time.

cheers,
rob    :-)

Go Up