Go Down

Topic: arduino-1.8.6 error with programming with usbasp + solution option (Read 356 times) previous topic - next topic

selevo

But I do not see anything in this arduino message that would indicate a solution

Code: [Select]
avrdude: Version 6.3-20171130
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "R:\arduino-1.8.6\hardware\tools\avr/etc/avrdude.conf"

         Using Port                    : usb
         Using Programmer              : usbasp






i replaced avrdude.exe on  100% work version (Today I tested it with my USBasp) and recived this message
Code: [Select]

avrdude: Version 6.3, compiled on Feb 17 2016 at 09:25:53
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "R:\arduino-1.8.6\hardware\tools\avr/etc/avrdude.conf"
avrdude: error at R:\arduino-1.8.6\hardware\tools\avr/etc/avrdude.conf:1133: programmer type jtagice3_updi not found
avrdude: error at R:\arduino-1.8.6\hardware\tools\avr/etc/avrdude.conf:1133: programmer type jtagice3_updi not found

avrdude: error reading system wide configuration file "R:\arduino-1.8.6\hardware\tools\avr/etc/avrdude.conf"


I think Arduino 1.8.6 sends the wrong keys for avrdude or Arduino avrdude incorrect

now I have in addition replaced "avrdude.conf" in\arduino-1.8.6\hardware\tools\avr\etc\
and  now good work


solution option

i replaced avrdude.exe in \arduino-1.8.6\hardware\tools\avr\bin\

and
avrdude.conf" in\arduino-1.8.6\hardware\tools\avr\etc\
on original files on avrdude sites

(avrdude.exe in arduino maybe not original and I do not know where they got him from )



pert


selevo


pert

There's one important line of the output you didn't provide and it's only partially shown in the screenshot. Please copy the last line of output before "avrdude: Version 6.3-20171130". This is the command the Arduino IDE generated to run avrdude.

Did the problem only start after you updated to Arduino IDE 1.8.6, or did you never try programming with the USBasp programmer with an earlier version of the Arduino IDE?

selevo

I previously used this programmer in other versions
now I have only 1.8.6

all text
Code: [Select]

Скетч использует 930 байт (2%) памяти устройства. Всего доступно 32256 байт.
Глобальные переменные используют 9 байт (0%) динамической памяти, оставляя 2039 байт для локальных переменных. Максимум: 2048 байт.
R:\arduino-1.8.6\hardware\tools\avr/bin/avrdude -CR:\arduino-1.8.6\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -cusbasp -Pusb -Uflash:w:r:\TEMP\arduino_build_808489/Blink.ino.hex:i

avrdude: Version 6.3-20171130
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "R:\arduino-1.8.6\hardware\tools\avr/etc/avrdude.conf"

         Using Port                    : usb
         Using Programmer              : usbasp



pert

I previously used this programmer in other versions
Did you ever have this problem with the previous IDE versions?

selevo

there is no such thing
I remember if there were mistakes, then arduino gave out a message pushing to the solution
Now in 1.8.6 this message is just empty and useless

In a few hours I'll try on older versions.

selevo



i replaced avrdude.exe on  100% work version (Today I tested it with my USBasp) and recived this message
Code: [Select]

avrdude: Version 6.3, compiled on Feb 17 2016 at 09:25:53
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "R:\arduino-1.8.6\hardware\tools\avr/etc/avrdude.conf"
avrdude: error at R:\arduino-1.8.6\hardware\tools\avr/etc/avrdude.conf:1133: programmer type jtagice3_updi not found
avrdude: error at R:\arduino-1.8.6\hardware\tools\avr/etc/avrdude.conf:1133: programmer type jtagice3_updi not found

avrdude: error reading system wide configuration file "R:\arduino-1.8.6\hardware\tools\avr/etc/avrdude.conf"


I think Arduino 1.8.6 sends the wrong keys for avrdude or Arduino avrdude incorrect

pert

That is the expected error when using an avrdude.conf written for the newest version of avrdude with an older version of avrdude. You're on the wrong track.

If you want to use an older version of avrdude with Arduino IDE 1.8.6, the easiest way to do it is to install an older version of Arduino AVR Boards:
  • Tools > Board > Boards Manager
  • Wait for the downloads to finish.
  • Click on "Arduino AVR Boards by Arduino"
  • Select "1.6.21" from the dropdown version menu.
  • Click on "Install".
  • Wait for the installation to finish.
  • Click "Close".
  • Sketch > Upload Using Programmer

selevo



I only want that the Arduino worked right after the download.
i installed "1.6.21" and "1.6.20" versions - no effect


now I have in addition replaced "avrdude.conf" in\arduino-1.8.6\hardware\tools\avr\etc\
and  now good work


solution option

i replaced avrdude.exe in \arduino-1.8.6\hardware\tools\avr\bin\

and
avrdude.conf" in\arduino-1.8.6\hardware\tools\avr\etc\
on original files on avrdude sites

(avrdude arduino maybe not original and I do not know where they got them from )

Kirjain_

Hi,

I'm having the exact same problem on Ubuntu 16.04. Which "original files" are you referring to? I downloaded the avrdude package from here but after extracting, I can't find the right files (avrdude executable and avrdude.conf) inside. I do find avrdude.conf.in, and replaced the <arduino-version>/hardware/tools/avr/etc/avrdude.conf file with it (and renamed it to avrdude.conf) but got a syntax error:
Code: [Select]
avrdude: Version 6.2
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "/usr/share/arduino-1.8.7/hardware/tools/avr/etc/avrdude.conf"
avrdude: error at /usr/share/arduino-1.8.7/hardware/tools/avr/etc/avrdude.conf:1158: syntax error
avrdude: error reading system wide configuration file "/usr/share/arduino-1.8.7/hardware/tools/avr/etc/avrdude.conf"


A bit stupid of me to hope it would be easily fixed...

And installing version 1.6.21 of arduino AVR boards as suggested by pert didn't work for me either...

Has anyone else been able to fix the issue on Ubuntu?

Best

pert

I do find avrdude.conf.in, and replaced the <arduino-version>/hardware/tools/avr/etc/avrdude.conf file with it (and renamed it to avrdude.conf) but got a syntax error:
That's a patch file. It's intended to make changes to the existing avrdude.conf file. You can't just rename it. This is the cause of the syntax error.

Code: [Select]
avrdude: Version 6.2
Why is it using AVRDUDE 6.2?

Go Up