Go Down

Topic: WIZ810MJ Problem with connection (Read 757 times) previous topic - next topic

simp

I have problem with connection WIZ810MJ to Arduino Duemilanove. I want to connect this module to Arduino and use library from Ethernet Shield(wiz5100). I made a schematic(see below). When I'm connecting my WIZ810MJ to Arduino and burn WebServer example only link led is lighting after connected to the router, and when is sending broadcast message RX led is blink.

Could any one please look at this schema and write what is wrong. Thx in advance!

robtillaart

#1
Mar 27, 2011, 07:01 pm Last Edit: Mar 27, 2011, 07:04 pm by robtillaart Reason: 1
No electric expert but you don't need a 5V voltage regulator when you use the 5V from the Arduino it is allready regulated.

You state you use the WIZ5100 library, is it compatible with the WIZ810MJ ?? Have you checked the datasheets?

Rob Tillaart

Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -
(Please do not PM for private consultancy)

Digger450


No electric expert but you don't need a 5V voltage regulator when you use the 5V from the Arduino it is allready regulated.

You state you use the WIZ5100 library, is it compatible with the WIZ810MJ ?? Have you checked the datasheets?



This module requires 3.3V and yes the module is compatible with the standard ethernet library.

@simp you need to connect the RESET line to a digital output pin with a 10k resistor.  Set the output HIGH for normal operation and you can toggle it to reset the module in code.

simp

Hi again,
Thank you for answer :)
Solution with RESET unfortunately doesn't work for me :/ I have also tried connect RESET from Arduino to WIZ810MJ RESET, but this also doesn't helped.

The WIZ810MJ module is working properly, because I can see that he interact with my router.

P.S. I have also Ethernet Shield(on W5100) and this module is working fine...

bubulindo

Have you checked that the Chip Select signal is connected in the same pin on your schematic and on the Arduino Ethernet Shield?

That could cause some problems. Have you doublechecked if there's no loose connections?
Eu não sou o teu criado. Se respondo no fórum é para ajudar todos mediante a minha disponibilidade e disposição. Responder por mensagem pessoal iria contra o propósito do fórum e por isso evito-o.
Se realmente pretendes que eu te ajude por mensagem pessoal, então podemos chegar a um acordo e contrato onde me pagas pela ajuda que eu fornecer e poderás então definir os termos de confidencialidade do meu serviço. De forma contrária toda e qualquer ajuda que eu der tem de ser visível a todos os participantes do fórum (será boa ideia, veres o significado da palavra fórum).
Nota também que eu não me responsabilizo por parvoíces escritas neste espaço pelo que se vais seguir algo dito por mim, entende que o farás por tua conta e risco.

Dito isto, mensagens pessoais só se forem pessoais, ou seja, se já interagimos de alguma forma no passado ou se me pretendes convidar para uma churrascada com cerveja (paga por ti, obviamente).

Go Up