Go Down

Topic: Trying to update the firmware from atmega2560 to atmega16u2 (Read 279 times) previous topic - next topic

prajwal98

I have arduino mega atmega2560 and wanted to use it as leonardo( trying to make arduino cursor ,keyboard)and for that I was trying to update the firmware  using FLIP software by ATMEL .
I connected the arduino , went to the DFU mode of the arduino by shorting the two pins of arduino, updated the firmware.
now the issue is my arduino ide no longer the recognize the port number of my connected arduino.
I am attaching the pics of device manager, how it look when i connect my arduino now.

spycatcher2k

OK - let me get this correct.

You reprogrammed the chip that supplies a serial interface to the ATMEGA2560 to be a keyboard/mouse, and now it does not work as a serial interface, weird, eh!

Mrs Drew
-=-
http://www.uk-pcb.co.uk - UK PCB Fab Company
I will design & code for you, but I will also charge you (PM me)
If you don't like my answers, realize : I'm not being cheeky, I'm Just trying to prompt you to use your own brain/google etc.

JeanRimbaud

For what it's worth, I had no luck with FLIP lately. It killed the DFU in a few 32u4 chips before I gave up on it -- like you, the devices disappeared from device manager. I also had problems with Atmel tools, apparently because the newer version of avrdude working behind the Arduino IDE is looking for different drivers than it used to.

I ended up using an Arduino Uno as ISP to load in the bootloader, which worked great.

akshitkumar

I have arduino mega atmega2560 and wanted to use it as leonardo( trying to make arduino cursor ,keyboard)and for that I was trying to update the firmware  using FLIP software by ATMEL .
I connected the arduino , went to the flipkart coupons DFU mode of the arduino by shorting the two pins of arduino, updated the firmware.
now the issue is my arduino ide no longer the recognize the port number of my connected arduino.
I am attaching the pics of device manager, how it look when i connect my arduino now.

I also have same issue

ShardulNayak

I have arduino mega atmega2560 and wanted to use it as leonardo( trying to make arduino cursor ,keyboard)and for that I was trying to update the firmware  using FLIP software by ATMEL .
I connected the arduino , went to the DFU mode of the arduino by shorting the two pins of arduino, updated the firmware.xbox 360 emulator for pc
now the issue is my arduino ide no longer the recognize the port number of my connected arduino.
I am attaching the pics of device manager, how it look when i connect my arduino now.
having same problem please help site admin

Go Up