Go Down

Topic: ESP PROBLEMA NO STA (Read 541 times) previous topic - next topic

SandroM

Olá,
tenho um esp8266 e uso como adaptardor um Uart. Estou usando o app Blink, quando tento conectar ele na minha rede aparece a seguinte info:

[609] Connecting to (xxx)

[13643] AT vession:0.40.0/0(Aug 8 2015 14:45:58(

SDK version:1.3.0

Ai,C:

[14679] Failed to set STA mode

antes eu ele estava dando runho, nem respondia, mudei a banda de transmissão para 115200 e passou a ter comunicação, aparentemente, mas com este Failed to set STA mode…

alguém pode me orientar?

Sou iniciante,
grato

giova014

#1
Sep 24, 2018, 08:24 pm Last Edit: Sep 24, 2018, 08:24 pm by giova014
Quote
tenho um esp8266 e uso como adaptardor um Uart
Você está usando um módulo como este?

Arduino!!

SandroM


SandroM


giova014

#4
Sep 25, 2018, 11:39 pm Last Edit: Sep 25, 2018, 11:40 pm by giova014
Eu realmente, por experiência, recomendo que você use o NodeMCU como este da foto:

É muito melhor em termos de programação, desempenho e estabilidade em relação a usar o módulo ESP-01 com Arduino Uno.
Arduino!!

SandroM

Sim, concordo, depois de penar aqui também pensei que eu devia ter comprado este NodeMCU... e o preço também sussa, já que pro esp8266 mais uart foi até mais

SandroM

Camarada, qual  NodeMCU  você sugere? grato

giova014

#7
Oct 01, 2018, 01:40 pm Last Edit: Oct 01, 2018, 01:43 pm by giova014
No MercadoLivre tem dois modelos:

Modelo 1: Modulo Nodemcu V3 Esp-12e Esp8266 Wi-fi Arduino


Modelo 2: Modulo Nodemcu Esp-8266 Esp-12f Ch340g V3 Wi- Fi


Sugiro comprar o Modelo 1 pois tem dimensões menores.
Arduino!!

Go Up