Go Down

Topic: Problemas com pinos 11 e 12 (Read 1 time) previous topic - next topic

Vinicius G.

Boa noite galera!  :)
Estou com uns problemas aqui e gostaria que vocês me ajudassem, seguinte...
esses tempos descobri um problema nos pinos 11 e 12 do meu arduino duemilanove, fui testar meu lcd 16x2 nele fiz as ligações certinhas sem curto sem nenhum detalhe e nao funcionou, o led que é ligado ao pino 13 ficava piscando numa velocidade maior do que piscaria com o blink, como se fosse um aviso. Troquei os pinos em que o lcd estava ligado e deu tudo certinho. agora fui fazer um projetinho uzando 5 leds e a mesma coisa tive que trocar os pinos porque nao funcionava nenhum led depois que tirei-os dos pinos 11 e 12 o projeto funcionou beleza o que pode ser? :smiley-eek:

Desculpe esse texto deste tamanho....

WebTronico.com

Você está conectando mais alguma coisa no Arduino alem dos 5 leds? (um shield por exemplo)

Os pinos 11 e 12 também são usados como MISO e MOSI por alguns shields.

TESTE: Se você ligar apenas 2 LEDs nos pinos 11 e 12, você consegue controla-los normalmente?
Abraço
Juliano

Vinicius G.

nao, nenhum shield apenas led mesmo assim eu consigo fazer blink nos pinos mais separadamente, exemplo so no pino 12 ou so no pino 11 mais mesmo assim o led do pino 13 ainda pisca o que pode ser?

Vinicius G.

Se eu fazer o upload de um programa que utilize algum destes pinos o led 13 fica piscando de uma forma como se fosse um alerta, agora se eu conectar um led por exemplo ele pisca numa velocidade rápida como se estivesse "dando Title" e se eu desconecto o led ele volta a piscar de uma forma como se fosse um alerta. Alguem me ajude por favor pois mes que vem vou precisar usar meu arduino e nem sei se as portas serão o suficiente  :smiley-eek:  =(  :smiley-eek-blue:

Vinicius G.

Ninguem vai responder nao? Ajuda ae...

Kotch

Nao é mais facil substituir o processador?
:smiley-eek:
????????????????????

Go Up