Go Down

Topic: troubleshoot no serial on programming port on due (Read 178 times) previous topic - next topic

terrylyons

Hi, I have a simple piece of code that was working perfectly on an Arduino duo/windows 10, and returning a stream of information to the computer via the serial interface at various baud rates.

I purchased a DUE board to increase the performance. I seem to be able to upload and compile code for the due successfully and set it running. The card connects to my machine reliably as com4. However, there seems to be no data coming back to my pc. I have tried different baud rates and always matched the pc and the card.

I read many issues but have no idea which are relevant. The board manager shows
Arduino SAM Boards (32-bits ARM Cortex-M3) by Arduino Version 1.6.11 INSTALLED

Thanks for your help.


Code: [Select]
void setup()
{
  Serial.begin(9600);
  // set up normalised raw input stream
  for(int i=0; i < in_dimension; i++)
    initial_raw_signal[i] = allRead(i);
}


Code: [Select]
void myprintfn ()
{   
    Serial.print(steps);
    Serial.print(",  \t");
    steps = 0;
    Serial.print(to_micros(updated_raw_signal[0]));
    Serial.print(":");
    {
      Serial.print(to_micros(updated_signal[0]));
      Serial.print(",");
    }
    for (int i=1; i < feature_dimension; i++)   
    {
      Serial.print(updated_signal[i]);
      //Serial.print(unscale(updated_signal[i], i));
      Serial.print(",");
    }
    Serial.print("\n");
}

pjrc

I was about to run your code to check if it works, but I see there's no loop() function.

Go Up