Go Down

Topic: arduino YUN V2.0 problem with package installation (Read 553 times) previous topic - next topic

jplam29

Oct 10, 2018, 01:24 pm Last Edit: Oct 10, 2018, 10:01 pm by jplam29
Hi, we bought a new Arduino YUN version (V2 = ABX00020). We want to install some package with these commands, who worked in the past with the last arduino version :
opkg update
opkg install kmod-rt2800-lib kmod-rt2800-usb kmod-rt2x00-lib kmod-rt2x00-usb python-openssl ftplib

Everything looks good, except for the ftplib … we have these messages after the last command :

Package kmod-rt2800-lib (4.9.91+2017-11-01-5) installed in root is up to date.
Package kmod-rt2800-usb (4.9.91+2017-11-01-5) installed in root is up to date.
Package kmod-rt2x00-lib (4.9.91+2017-11-01-5) installed in root is up to date.
Package kmod-rt2x00-usb (4.9.91+2017-11-01-5) installed in root is up to date.
Package python-openssl (2.7.14-10) installed in root is up to date.
Unknown package 'ftplib'.
Collected errors:
* opkg_install_cmd: Cannot install package ftplib.

Can you help us to understand what happened. Thank you.

root@Arduino:~# wget http://downloads.arduino.cc/openwrtyun/1/packages/ftplib_3.1-1-1_ar71xx.ipk
Downloading 'http://downloads.arduino.cc/openwrtyun/1/packages/ftplib_3.1-1-1_ar71xx.ipk'
Connecting to 158.69.81.61:80
Writing to 'ftplib_3.1-1-1_ar71xx.ipk'
Cannot open output file: File exists
root@Arduino:~# opkg install ftplib_3.1-1-1_ar71xx.ipk
Unknown package 'ftplib'.
Collected errors:
* pkg_hash_fetch_best_installation_candidate: Packages for ftplib found, but incompatible with the architectures configured
* opkg_install_cmd: Cannot install package ftplib.

root directly with http don't work more


ShapeShifter

Cannot open output file: File exists
Sounds like the package file (or some other file) already exists and it cannot overwrite it. Is the file set to read only? Is the drive full? Is the drive or the file corrupted?

Quote
root directly with http don't work more
I have no idea what you're trying to say here.

Go Up