Pages: 1 2 [3] 4 5 6   Go Down
Author Topic: TLC 5940 anschließen  (Read 8119 times)
0 Members and 1 Guest are viewing this topic.
Forum Moderator
BZ (I)
Offline Offline
Brattain Member
*****
Karma: 271
Posts: 21887
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo voithian
Ich sehe das so, daß wir uns ergänzen.
Gute Umsatzsteuer-dingsda.
Grüße Uwe
Logged

Offline Offline
God Member
*****
Karma: 6
Posts: 717
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ich finde es perfekt dass ihr beide antwortet, wie heisst es so schön: Doppelt hält besser  smiley-lol
Ich fühle mich perfekt aufgeklärt und kann schön ans Werk gehen am WE.

Das Thema 16-Bit Timer und FAST PWM hatte ich mir angeschaut, aber irgendwie nicht weitergekommen. Mag sein, dass ich das mit deiner Hilfe schneller hinbekommen hätte smiley-wink Andererseits, was wäre ein Leben ohne Herausforderungen
Das wird dann der nächste Step, wenn ich dies hier hinbekomme und merke, dass ich doch eigentlich viel viel lieber mit 16 Bit dimmen möchte  smiley-twist
Logged

Forum Moderator
BZ (I)
Offline Offline
Brattain Member
*****
Karma: 271
Posts: 21887
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Sei bescheiden; Bei 12 Bit siehst Du schon keine Stufen. 16 Bit braucht es wirklich nicht.
Grüße Uwe
Logged

Neuss
Offline Offline
Full Member
***
Karma: 1
Posts: 200
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Sei bescheiden; Bei 12 Bit siehst Du schon keine Stufen. 16 Bit braucht es wirklich nicht.

Hallo Uwe,

ich hatte mit currymuetze vor ca. 3 Wochen schon in einem anderen Thread über die Realisierung von PWM mit mehr als 8Bit diskutiert.

Dazu ist ja ein 16-Bit-Timer ganz nützlich/nötig , selbst wenn man nur mit 9 oder 10 Bit Auflösung arbeitet.

Ich persönlich bin ebenfalls der Meinung, dass man schon bei 512 Schritten keine Helligkeitsstufen mehr sieht.
Aber vielleicht liegts nur an meiner Brille. smiley-wink

Gruß
Wolfgang
Logged

Offline Offline
God Member
*****
Karma: 6
Posts: 717
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo,

ich habe ´jetzt zunächst mal den TLC standardmäßig (siehe meinen ersten Beitrag hier) verdrahtet.
Eine LED angeschlossen und dieses Programm hochgeladen:
Code:
#include "Tlc5940.h"

void setup()
{
  Tlc.init();
}

void loop()
{
  int i = 0;
  for (i; i < 4095; i++) {
     Tlc.clear();
     Tlc.set(1, i);
     Tlc.update();
     delay(10);
  }

}

Das sollte eigentlich die LED mal von o auf 4095 hochfaden, leider leuchtet die LED durchgängig, ohne das was passiert.
Ich vermute allerdings dass das nicht am Code liegt, könnt ihr das bestätigen?
Habe mal nen anderen Code (Blink withou delay hochgeladen) leuchtet trotzdem weiter

Gruß
« Last Edit: April 08, 2011, 12:46:23 pm by currymuetze » Logged

Forum Moderator
BZ (I)
Offline Offline
Brattain Member
*****
Karma: 271
Posts: 21887
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

müßte funktionieren. An welches Pin hast Du die LED angeschlossen?
Uwe
Logged

Offline Offline
God Member
*****
Karma: 6
Posts: 717
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

An PIN 1 (Der erste PIN auf der Seite wo alle 14 PINs liegen) 0 und 15 liegen ja auf der anderen Seite
Dann mss ich doch ncoh mal die Verkabelung checken.
Ich habe mich aber bei der Verkabelung nach der Anleitung für das MEGA Board gerichtet, der nutzt ja andere PINs am Ardino als das normale Board. Muss ich da dann den TLC COde anpassen?
Gruß
Logged

Forum Moderator
BZ (I)
Offline Offline
Brattain Member
*****
Karma: 271
Posts: 21887
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Pin 1 Stimmt.
Die Beschaltung hast Du ja in Deinem Beitrag Reply #21 angehängt
ansonsten nochmal:

von http://www.arduino.cc/playground/Learning/TLC5940
Grüße Uwe
Logged

Offline Offline
God Member
*****
Karma: 6
Posts: 717
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

sehr komisch, alles noch mal überprüft, finde den fehler nicht.
Gibt es unterschiedliche Versionen des TLC? Meine ist nicht die gleiche wie meistens abgebildet, siehe anhang mein tlc


* eBay_047_001 (1).JPG (38.24 KB, 596x447 - viewed 14 times.)
Logged

Neuss
Offline Offline
Full Member
***
Karma: 1
Posts: 200
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

sehr komisch, alles noch mal überprüft, finde den fehler nicht.
Gibt es unterschiedliche Versionen des TLC? Meine ist nicht die gleiche wie meistens abgebildet, siehe anhang mein tlc
Hallo,
das sieht ja schon ein wenig eigenartig aus. smiley-confuse
Wenn du im Datenblatt auf Seite 6 nachsiehst, haben ja offensichtlich die SMD-Variante auf dem Platinchen und die DIP-Ausführung ganz unterschiedliche Pin-Belegungen. Und wenn ich das auf deinem Foto richtig erkenne, erfolgt da keine Umsetzung (d.h. Pin 1 vom Chip geht auf Pin 1 der Platine, Pin 2 auf Anschluss 2, usw.). Damit wären für deine Verdrahtung ja die Pins des SMD-Chips zutreffend.

Link zum Datenblatt:http://focus.ti.com/lit/ds/symlink/tlc5940.pdf
Das solltest du vielleicht noch mal überprüfen.

Gruß
Wolfgang
Logged

Offline Offline
God Member
*****
Karma: 6
Posts: 717
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo WOlfgang,

vielen Dank für den Hinweis, damit könntest du richtig liegen.
Werd mir das mal anschauen, hoffe das ist der Grund.
Gruß
Thorsten
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 26
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo Uwe,

mit welchem Programm hast Du den den tollen Aufbau gemalt?

Das kenne ich nicht.

Gruß
Thomas
Logged

Offline Offline
God Member
*****
Karma: 6
Posts: 717
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

So, hab zuviel rumgelötet und die kontakte sind im arsch...damit liegt das Projekt nun erst mal auf Eis smiley-sad
Trotzdem Danke
Logged

Germany
Offline Offline
Edison Member
*
Karma: 48
Posts: 2338
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Das ist natürlich schade. Beim nächsten Mal am besten Stiftleisten anlöten und die Platine direkt ins Steckbrett stecken. Für spätere Schaltungen ohne Steckbrett kannst du dir dann gleich die passenden Buchsenleisten zulegen.
Logged

Mein Arduino-Blog: http://www.sth77.de/ - letzte Einträge: Teensy 3.0 - Teensyduino unter Window 7 - Teensyduino unter Windows 8

Forum Moderator
BZ (I)
Offline Offline
Brattain Member
*****
Karma: 271
Posts: 21887
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo Uwe, mit welchem Programm hast Du den den tollen Aufbau gemalt? Das kenne ich nicht.
Hab nicht ich, einfach verlinkt von http://students.washington.edu/acleone/codes/tlc5940arduino/img/breadboard-arduino-tlc5940_close.png
Ist mit Fritzing gmacht: http://fritzing.org
Grüße Uwe
Logged

Pages: 1 2 [3] 4 5 6   Go Up
Jump to: