Go Down

Topic: Arduino Uno + Waveshare GSM/GPRS/GPS Shield (B) (Read 136 times) previous topic - next topic

Greg16

Hello!
I have a quick question regarding to waveshare module from the topic. I have already checked communication between arduino and waveshare module and everything seems to work fine, but to startup module for the first time you have to pull down  power button for few seconds. Another way to boot module is to use some pinout. As i have checked you have to use analog pin A5 from arduino uno. How to do that? I tried to set A5 pin as below and it doesn't work. Here is further documentation of waveshare module:
pinouts: https://www.waveshare.com/w/upload/1/10/GSM-GPRS-GPS-Shield-B-Schematic.pdf
documentation: https://www.waveshare.com/w/upload/e/e8/SIM808_Hardware_Design_V1.02.pdf (page 24)

First in "setup" section i have declared pin: pinMode(A5,OUTPUT);
and then in loop:
analogWrite(A5,HIGH);
delay(3500);
analogWrite(A5,LOW);

Thank you in advance for any response.

pylon

try this:

Code: [Select]
pinMode(A5, OUTPUT);
digitalWrite(A5, HIGH);
delay(3500);
pinMode(A5, INPUT);

Greg16

I'm afraid it didn't help... I tried different delay times but without any progress. Can i check somehow if Uno gives proper voltage? Is it matter whether I plugged to power only arduino or arduino + waveshare module with separate charger?

pylon

Quote
but to startup module for the first time you have to pull down  power button for few seconds.
How long exactly? If the module starts when you push the button for 3 seconds above code should work, given the schematics are correct.

Quote
Can i check somehow if Uno gives proper voltage?
Set the delay much higher and check the A5 voltage to GND with a multimeter.

Go Up