Pages: [1]   Go Down
Author Topic: [Solved]Arduino Uno usb setup issues  (Read 548 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello, I am new to arduino. I recently just purchased an Uno (surface mounted version) from sparkfun. I am following the tutorials from this site ( http://arduino.cc/en/Tutorial/DigitalReadSerial ) and I have ran into an issue on my second lesson. I am able to upload sketches, but I am not able to use the serial monitor. I am wondering where I went wrong on my setup. I get an error as follows:

http://pastebin.com/Wx6G4yZs
edit: or
http://pastebin.com/Mw6Sr8PW

when I attempt to use it. I am running Ubuntu 10.04 LTS - the Lucid Lynx 64 bit. I have installed thee rxtx package. dmesg shows:

Code:
[  850.430247] usb 4-3: USB disconnect, address 2
[  863.200575] usb 4-3: new full speed USB device using ohci_hcd and address 3
[  863.430257] usb 4-3: configuration #1 chosen from 1 choice
[  863.434059] cdc_acm 4-3:1.0: ttyACM0: USB ACM device

My preferences.txt file is pastebin'd here : http://pastebin.com/sH3UPA1k
I have attempted to run as root and it did not fix the issue.

2nd edit:
Code:
sudo aptitude remove brltty
fixed it for me after a reboot just long enough for me to upload another sketch, however the moment I tried to view the serial console I am back where I started from. I am curious to know what boards need to have the firmware updated. I have the smd version and I do not know where the serial number is, or which ones are bad.
Code:
sudo lsusb -v -d 2341: | grep bcdDevice
gives me:
Code:
bcdDevice            0.00

« Last Edit: April 04, 2011, 05:02:58 pm by _cj_ » Logged

Colorado
Offline Offline
Full Member
***
Karma: 2
Posts: 220
Arduino 0022 and Ubuntu 11.10 64bit.
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Try the following command with the UNO plugged into the usb port and the serial console open.  Please post the output.

 lsof 2>&1|grep ttyACM
« Last Edit: April 04, 2011, 01:26:34 pm by mrtaylor » Logged

Colorado
Offline Offline
Full Member
***
Karma: 2
Posts: 220
Arduino 0022 and Ubuntu 11.10 64bit.
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
bcdDevice            0.00
old firmware
Quote
what boards need to have the firmware updated
Atmega8U2 firmware: my opinion, if your running linux all the Uno boards. 
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ok... I was a bit skeptical having just purchased a brand new board and finding out I need to attempt something that could destroy it (afaik) in order to do anything other than blink an led. Being a Linux user, I know that NOTHING is ever easy to do when it comes to this sort of OS, so I just decided I'd grow a pair and update the firmware -- after all money is only paper right? Well all is well, and my serial issues are no longer existent.

http://arduino.cc/en/Hacking/DFUProgramming8U2
the most informative being this single picture from this post:
http://arduino.cc/forum/index.php/topic,53290.msg380874.html#msg380874

made this process absolutely simple. Thank you.

Why are these devices still shipping with an older firmware if a new one appears to fix several issues?
« Last Edit: April 04, 2011, 05:06:48 pm by _cj_ » Logged

Pages: [1]   Go Up
Jump to: