Go Down

Topic: Flashing DUE (Read 259 times) previous topic - next topic

wizwik

I have a Due board with a ATSAM3X8 processor.  I have downloaded BOSSA from Shumatech and have it loaded and running.

I am using Windows 7 and it downloaded a USB driver that seems to work ok. I was able to read the Flash memory from the board. If I used HEX as the file extension, it did write a file but it is not in Hex. It seems to be in binary.

I have looked at a number of articles on Goggle on how to get the hex file but I find that, for this processor, the Arduino Sketch/Export Complied Binary only outputs to  .bin file.

I used BOSSA to flash the file into the processor and that run without any errors. It showed pages being loaded  as I expect. 

My problem is that when I do a reset on the processor, the code does not run. If I take the processor and load up a program from Arduino, it works fine, so I conclude the processor is fine.

I have tried it on the programming and native ports for the flashing process but it won't run with a Reset to the processor. I used the Erase checkbox before I do the flash write process.

When I do an Info command, it reports the correct processor.

Any help would be appreciated. I think I am very close to have it work. >:(

Thanks

ard_newbie

If you add a small capacitor between the reset pin and a Gnd pin, the board should run after a reset:

https://forum.arduino.cc/index.php?topic=256771.75

wizwik

Thanks for the advice. I find that the board will run after a reset if I load the program via the Arduino IDE and then press Reset.  So I think there is still something wrong with the file I have loaded to the Due board with BOSSA. I don't think there is a problem with the Reset.

wizwik

I found the problem.  I was not checking the  Boot to Flash option on the Bossa main screen.   It was the configuration of the Boot source.  Are_newbie, I may use your solution for another problem. Thanks all

Go Up