Go Down

Topic: Laufschrift einer Led Matrix (Read 897 times) previous topic - next topic

uwefed

Ich versorge meine Led's mit 2 Netzteilen die jeweils die hälfte versorgen. Das ist nicht das Problem.
Hast Du da Schutzwiderstände in der Datenleitung  Zwischen den 2 Blöcken, die mit verschidenen Netzteilen versorgt werden. und zwischen Arduino und 1. Block?
Grüße Uwe

fehlkauf_1234

#16
Oct 25, 2018, 09:22 am Last Edit: Oct 25, 2018, 10:06 am by fehlkauf_1234
Hast Du da Schutzwiderstände in der Datenleitung  Zwischen den 2 Blöcken, die mit verschidenen Netzteilen versorgt werden. und zwischen Arduino und 1. Block?
Grüße Uwe
Ich hatte immer einen Widerstand vor der ersten LED, aber ich hab ihn jetzt weggelassen.
Windgeräusche bei 330 km/h; ich weiß nicht weiter!

postmaster-ino

Hi

Das kann Dir beim Zusammenstecken schon die erste LED töten - spreche Da aus Erfahrung und: SMD löten ist ... nicht so geil, wie Alle immer behaupten ... oda so!

MfG
anscheinend ist Es nicht erwünscht, einen Foren-internen Link als 'Homepage' einzubinden, damit JEDER nur einen Klick von combie's Liste zum Thema State-Maschine entfernt ist.
... dann eben nicht ...

fehlkauf_1234

#18
Oct 26, 2018, 07:59 am Last Edit: Oct 26, 2018, 08:21 am by fehlkauf_1234
Hi

Das kann Dir beim Zusammenstecken schon die erste LED töten - spreche Da aus Erfahrung und: SMD löten ist ... nicht so geil, wie Alle immer behaupten ... oda so!

MfG
Danke für den Tipp
Windgeräusche bei 330 km/h; ich weiß nicht weiter!

Helmuth

#19
Oct 26, 2018, 09:17 am Last Edit: Oct 26, 2018, 09:18 am by Helmuth
Falls die Hardware irgendwann steht und es tatsächlich um die Software geht: Es gibt die FastLED LEDText Library.

Video. Und noch ein Video.

Ich habe die selbst nie benutzt, aber in der FastLED Community ist das Ding Standard.

Beste Grüße,

Helmuth

fehlkauf_1234

Falls die Hardware irgendwann steht und es tatsächlich um die Software geht: Es gibt die FastLED LEDText Library.

Video. Und noch ein Video.

Ich habe die selbst nie benutzt, aber in der FastLED Community ist das Ding Standard.

Beste Grüße,

Helmuth
Alles kla danke für die Nachricht
Windgeräusche bei 330 km/h; ich weiß nicht weiter!

Tommy56

In Wirklichkeit habt Ihr dem armen TO keinen Schritt weiter gebracht, wie er nebenan vermeldet.

Gruß Tommy
"Wer den schnellen Erfolg sucht, sollte nicht programmieren, sondern Holz hacken." (Quelle unbekannt)

Moko

im Originalsketch hieß es noch:  
Code: [Select]
uint8_t charBuffer[8][8];

du hast  
Code: [Select]
uint8_t charBuffer[10][10];
draus gemacht, die Zeichen sind aber immer genauso groß wie im Originalsketch.
Was passiert wenn du die Originalanweisung benutzt?


fehlkauf_1234

im Originalsketch hieß es noch: 
Code: [Select]
uint8_t charBuffer[8][8];

du hast 
Code: [Select]
uint8_t charBuffer[10][10];
draus gemacht, die Zeichen sind aber immer genauso groß wie im Originalsketch.
Was passiert wenn du die Originalanweisung benutzt?


Ich habe auch 8 ausprobiert.Geändert sich nix ,zumindestens ist mir nichts aufgefallen.
Windgeräusche bei 330 km/h; ich weiß nicht weiter!

Rotzbox

#24
Jan 12, 2019, 04:36 am Last Edit: Jan 12, 2019, 04:40 am by Rotzbox
Hallo fehlkauf !!!

Ich sitze seit Tagen vor dem gleichen Problem wie Du....
Mein Tisch hat allerdings zur Zeit 300 LEDs  30 x 10.

Da ich wohl genauso viel Ahnung wie Du Habe was die Buchstaben Anordnung und den Zeilenversatz oder die Spieglung jeder zweiten Zeile angeht....
Also ich fand einige Beiträge hier schon sehr Hilfreich.   
Ich werde mich als nächstes mal mit der FastLED Library auseinandersetzten um zu verstehen wie der original Sketch mit 12x12 LEDs funktioniert....
Ich habe im Sketch diverse Zahlen verändert um zu sehen was passiert und um daraus zu erkennen was der Befehl macht....

also bei mir kann ich jetzt schon die Menüpünkte recht gut lesen. Viel besser als noch zu Beginn...   
Sobald ich am Rechner sitze stelle ich meinen Code hier zur Verfügung!,

Gibt es bei Dir neues zu berichten? 
Würde mich freuen wenn du Deine neusten Erkenntnisse mit mir oder besser mit uns teilst.   Sobald ich was neues hab melde ich mich hier wieder !!!


fehlkauf_1234

Gude

Ich habe meine Matrix jetzt in 16x16 umgebaut. Mein Grundprogramm scheint nur zu so einer Matrix zu passen. Klappt es bei dir jetzt?
Windgeräusche bei 330 km/h; ich weiß nicht weiter!

uwefed

@fehlkauf_1234

Ich fine es total unkollegial, egoistisch und ausbeuterisch daß Du Deinen ersten POST mit der Fehlerbeschreibung gelöscht hast.
Wir helfen Dir, aber nicht nur Dir, sondern allen, die das ein ähnliches Problem haben und durch unsere Antworten geholfen werden könnte. Mit Deinem Verhalten verhinderst Du das.

Uwe
Moderator

fehlkauf_1234

@fehlkauf_1234

Ich fine es total unkollegial, egoistisch und ausbeuterisch daß Du Deinen ersten POST mit der Fehlerbeschreibung gelöscht hast.
Wir helfen Dir, aber nicht nur Dir, sondern allen, die das ein ähnliches Problem haben und durch unsere Antworten geholfen werden könnte. Mit Deinem Verhalten verhinderst Du das.

Uwe
Moderator
Sorry! Habe Fehlerbeschreibung wieder eingefügt.

Lg
Windgeräusche bei 330 km/h; ich weiß nicht weiter!

Go Up