Pages: [1]   Go Down
Author Topic: Arduino Duemilanove not working - Tx/Rx always lit  (Read 1502 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi all,

My Duemilanove is not working.  I've been using it for about a month now with no problems.  It spontaneously stopped working yesterday, and I made no changes to the physical configuration before it stopped working.  Here's my setup that I've been using for about a week:

1) Powered externally using a 9V battery
2) Connected to my PC with a USB cable for sending data serially (Windows 7 64-bit)
3) 3.3V pin is connected directly to AREF, analogReference(EXTERNAL) is being called before analogRead(pin).
4) two analog signals within 0-3V connected to analog pins 0 and 1

Here's the problem:
1) my computer is not recognizing that anything is connected to the computer, the COM port isn't showing up in device manager or anything.  I'm connecting directly to the computer (not through a hub) and I've tried multiple USB ports and I've tried restarting my computer.
2) when I connect the Arduino to a linux machine and use "lsusb", the Arduino isn't showing up in the list of devices
3) the Rx Tx LED's are always lit.  They don't flicker; they're just on all the time, regardless of how I'm powering the Arduino

I've done some reading and it seems that the Rx and Tx lights staying lit is bad news.  Does anybody have any idea how to fix this, or if perhaps I managed to fry my FTDI chip?

Thanks!
Logged

Left Coast, CA (USA)
Offline Offline
Brattain Member
*****
Karma: 331
Posts: 16523
Measurement changes behavior
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
or if perhaps I managed to fry my FTDI chip?

It's possible. The 3.3v from a Duemilanove board comes from the internal 3.3v regulator inside the FTDI chip. It has a maximum current rating of only 50ma. If you somehow managed to exceed that rating you might have toasted the FTDI chip. The fact that the PC doesn't see the USB connection when you first plug in the board is not a good sign. If you have anything wired to the board try removing it and see if that helps. Lastly you can removed the 328 processor chip from the board and then try plugging in the USB cable and see if the PC 'sees' the connection. If not it's most likely the FTDI is bad. That is a hard chip to replace as it's a SMD device and special tools and experance is needed to unsolder and solder in a replacement.

Lefty

« Last Edit: April 04, 2011, 11:55:59 am by retrolefty » Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks for the quick reply!

Quote
It has a maximum current rating of only 50ma.

I checked the atmega328 datasheet, and it says that there's a 1..100Kohm resistor connected to the input to the ADC, which should limit the input current to 3.3mA (1..100Kohm?). Also, the ADC is designed for connections with a 10Kohm or less output resistance; since the 3.3V pin outputs a maximum of 50mA then it should fall well within this 10Kohm max.  Am I missing something here?

Also, I've completely disconnected everything from the board before connecting it to the PC and I get the same issue.  I'll try removing the atmega328 chip and connecting that to my computer at the next opportunity I get.

Thanks for the help.
Logged

0
Offline Offline
Shannon Member
****
Karma: 161
Posts: 10445
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

No, the AREF input is also an output.  You should connect it via a resistor to be safe (1k or so?).  In particular until you call analogReference (EXTERNAL) it is connected to the internal 1.1V reference - so connecting it directly to the 3V3 supply is connecting a 3.3V supply to a 1.1V reference - something is going to be overloaded...
Logged

[ I won't respond to messages, use the forum please ]

Pages: [1]   Go Up
Jump to: