Go Down

Topic: serial read problems with maxuino, max2arduino,... (Read 634 times) previous topic - next topic

hello,

im using the latest maxuino the arduino with firmata->standartfirmata and the latest max5. i also installed the new drivers.

max sees the arduinoport but when i want to read a button in max, i always get alot of noise with it. as soon as i put a pin to outputmode its flickering between 0 and 1, tending to stay at one. when i press it, it tends to stay at zero, but well sometimes there is alot of noise in between.

i have an arduino duemilanove. i also tried the arduino uno and my old arduino NG. same results. i really dont know what else to do and i couldnt find anyone with similar problems. maybe im just too stupid, and its just some little thing that i forgot. if so, please give me a hint.

i also tried it on two different computers  (both macs, with osx 10.6) and even different approaches like max2arduino. it always seems to work, but then suddenly there is this noise.

somebody has any idea?


cheers






PaulS

Quote
as soon as i put a pin to outputmode

You should not be setting the mode to output for things you want as input. Why would you do that?

i mean inputmode, sorry.

well, i decided to use an old usb-keyboard and solder my bitton to it. i just need one button.

thanks for replying.

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy