Go Down

Topic: Rotary Encoder troubles (Read 611 times) previous topic - next topic

AeroNotix

Apr 06, 2011, 07:41 pm Last Edit: Apr 07, 2011, 09:51 pm by AeroNotix Reason: 1
I picked up a Rotary Encoder today from an Electronics shop.

I do not speak the native language in the country I am in, so I couldn't manage to get the pin-out for this encoder.

Anyway, it's a 4 pin device, assuming I correctly picked up an encoder. I cannot get this thing to work.

I am thinking that since it's a four pin encoder, I have to supply 5v to it. Would this mean I do not need to use pull-up resistors on the encoder pins?

Secondly, it could be I just haven't got it hooked up right, but there's only four pins and I've been messing with it for nearly 5 hours so I think I've tried every combo.

Any help would be appreciated.



EDIT: Went back to the shop and they swapped it. Since found out it wasn't a rotary encoder it was a rotary switch. FML.

Protip: Learn the language of the country you're in.

Grumpy_Mike

Use a meter and test the continuity between the terminals.
If it is a switch type then you will see two pairs making and breaking contact.
Then you need to wire it up with the common to ground, other connectors to the two inputs and enable the pull up resistors or have external ones.

AeroNotix

It's not a switch type, I thought that too.

I can't even get a reading when I set my multimeter to 'diode' to see if it's an optical type either...

RuggedCircuits

Are there any markings at all on this thing? Any way you could post a picture?  Worst case: it's a broken 4-pin rotary encoder.

--
The Gadget Shield: accelerometer, RGB LED, IR transmit/receive, speaker, microphone, light sensor, potentiometer, pushbuttons

AeroNotix

CTR is the only thing that's on it.

I have googled until my fingers bled, I cannot find any Encoder with that marking.

Maybe you have some google-fu I do not posses?

Go Up