Go Down

Topic: Sudden Upload Hell (Read 519 times) previous topic - next topic

Steppenwolf

Everything was just dandy, then I went to upload some new code, and now I'm getting the dreaded:

Binary sketch size: 9962 bytes (of a 32256 byte maximum)
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding

The orange LED flashes after I press upload.

Here is what I get when I shift + upload:

inary sketch size: 9962 bytes (of a 32256 byte maximum)
/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/bin/avrdude -C/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf -v -v -v -v -patmega328p -cstk500v1 -P/dev/tty.usbmodem411 -b115200 -D -Uflash:w:/var/folders/0+/0+D9XgR2GgGAwHnsnA+EpU+++TI/-Tmp-/build5808493057493927597.tmp/sketch_apr06a.cpp.hex:i

avrdude: Version 5.4-arduino, compiled on Oct  9 2007 at 11:20:31
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

         System wide configuration file is "/Applications/Arduino.app/Contents/Resources/Java/hardware/tools/avr/etc/avrdude.conf"
         User configuration file is "/Users/Ryan/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port            : /dev/tty.usbmodem411
         Using Programmer      : stk500v1
         Overriding Baud Rate  : 115200
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv: . [00]
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: Send: Q [51]   [20]
avrdude: ser_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding

What can I do?

Thanks in advance!!

mellis

You're on a Mac, right?  What version of OS X?  What board?

Did you try a different USB cable?  And try connecting the board straight to the computer without going through a hub or keyboard, etc.

What were you doing before it stopped working?

Steppenwolf

Yes I'm using OSX 10.6.7 macbook pro, and an Uno.  I have not tried a different cable.  Should I get one?  All I did was change a little piece of code. Hrmmm

Steppenwolf

I just tried it on my friend's macbook air running 10.6.7 and got the same thing.

Go Up