Go Down

Topic: Upload error on Arduino Nano, ATmega328P (Read 99 times) previous topic - next topic

DannyPhunk

Hey guys, first attempt to upload to my arduino board thats part of a synth build I'm putting together, but no matter what I try in the troubleshooting guide I just can't get it to work! Hope someone can help
Code: [Select]

Arduino: 1.8.7 (Windows 10), Board: "Arduino Nano, ATmega328P"

Sketch uses 3288 bytes (10%) of program storage space. Maximum is 30720 bytes.
Global variables use 27 bytes (1%) of dynamic memory, leaving 2021 bytes for local variables. Maximum is 2048 bytes.
C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM3 -b115200 -D -Uflash:w:C:\Users\DANIEL~1\AppData\Local\Temp\arduino_build_747677/grainsV21.ino.hex:i

avrdude: Version 6.3-20171130
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

         Using Port                    : COM3
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00

avrdude done.  Thank you.

An error occurred while uploading the sketch

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.


Any help is welcomed and thank you in advance!

sterretje

#1
Nov 09, 2018, 09:35 am Last Edit: Nov 09, 2018, 09:36 am by sterretje
Have you considered to use the search on this forum or google?

See e.g. https://forum.arduino.cc/index.php?topic=577524.0 and many more.

Most often it's fixed by selecting 'old bootloader' from tools->processor.
If you understand an example, use it.
If you don't understand an example, don't use it.

Electronics engineer by trade, software engineer by profession. Trying to get back into electronics after 15 years absence.

paulinha

I had this same problem with my Arduino Nano. But I managed to solve this problem by installing the CH340 drive on my computer.  :D

Go Up