Go Down

Topic: Problem communicating with Atmega8! (Read 785 times) previous topic - next topic


Hello, second attempt because nobody read my first (which I deleted now)...

I built a single-sided Arduino S3V.3 R.2 with an Atmega 8 and a parallel programmer cable as pictured on the Arduino site (the 3-resistor version, about 40cm long).

Attached are photos of the board, the transistors are the proposed ones (BC547+557) and the 10u cap is bipolar. Are the types of capacitors uncritical?

I tried to burn the bootloader using Arduino 0007, 0010 and 0022, but the parallel as well as the serial port never seemed to be able to make communication with the AVR! I'm always getting the same results ("AVR device not responding") - with the parallel cable plugged onto the ICSP, just as with the board completely disconnected from the PC.

The "pin13" LED shines dimly but gets dark for a moment when I try to burn the bootloader, also the RX and TX pins light up when I try to make serial communication, so I don't think it's my ports.

I measured these connections from the printer port right to the Atmel's pins and everything's fine. Also, I measured the corresponding voltages at the respective pins with the Arduino software running but on halt:

16   |     1   |   4,6V  (Reset)
  2   |   17   |   4,5V  (MOSI)
11   |   18   |   4,5V  (MISO)
  1   |   19   |   2,4V  (SCK)
18   |   22   |      0V  (AGND)

VCC is 5V as expected.
I thought that SCK might have too much voltage drop because of the LED, but communication didn't work as well with the LED unsoldered.

I think when I first tried to burn the bootloader using Arduino 0022, I didn't make any changes to the prefs file, but selected "older w/ Atmega8", could I have messed the fuse bits anyhow? Or is there some way in which I could have killed the AVR? (order of cables plugged in/out etc.)

Thanks a million for help, I'm really getting desperate here!


Ah yes, I forgot: I use WinXP and have giveio installed.

I don't have a universal development board and don't really feel like buying one, just for writing the bootloader onto that chip once!


OK, I solved it: I put the resistor of pin13 into a socket, removing it when using the icsp, since it caused too much voltage drop on SCK using the dapa programmer. Don't know why it wasn't working the first time I removed that resistor, probably I just got some (software) settings wrong...
I can burn bootloader using Arduino 0007.

Go Up