Pages: [1]   Go Down
Author Topic: Accidentally ran 12vdc into 5v out pin. Did I kill my uno?  (Read 759 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi

I just got my new uno the other day and have been happily playing with it. This morning, I accidentally wired an external 12vdc power supply directly into the +5vdc output pin on the board. I disconnected the 12v within seconds but now the board is unresponsive except for the "on" light. The computer doesn't see it on the USB port.

Have I essentially fried the whole board? Is there any way to tell what the extent of the damage is: like could it just be the ATmega328 chip? I'm guessing that if it's not talking on the USB port that both controllers are pretty much cooked.

Any help would be appreciated.

Thanks,

Scott
Logged

Connecticut
Offline Offline
Edison Member
*
Karma: 17
Posts: 1216
RTFD (Datasheet in our case)
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

The problem is that on most electronics, all 5V's are wired together and all GND's are wired together. So everything directly connected to the 5V bus is fried. smiley-sad Look at the arduino schematic to find out what parts are fried. Note that LEDs can handle pretty high voltages as long as they have current-limiting resistors, they're just like diodes. Good Luck! You may need a new board.
Logged

Houston
Offline Offline
Jr. Member
**
Karma: 0
Posts: 95
Electronics is just part of life.
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Probably most of your system is fried. Something you could do is plug it in via usb and check to see if the 5v 3v3 and the ground still work. it'll help you see if you can still use it in the future.

Something similar happened to me. I had plugged it into a wall plug that was about 24v. It friend my atmega and i had to buy another arduino. but when i started buying more atmega328's i noticed that the usb interface on the arduino wouldn't work but if i preprogrammed another atmega with my new arduino and put it in to the fried one and then connect it through usb just for power then the arduino would run just fine! =) just a note.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

That's a great idea, to use the otherwise dead uno board with a sister uno to program the atmega chip. I've already ordered a new uno, figuring the usb controller was toast along with the main atmega chip. There is some solace in knowing that I can at least re-use the old uno board to host a healthy atmega chip programmed on a healthy uno, and be able to take advantage of those nice hardware interface connections. Now the old fried one can be my test-dummy, so to speak.

Thanks for the tip, Baum. And thanks Leonidas for the confirmation in how overvoltage will unmercifully fry cmos microcontrollers.

Last time I do that! Lesson learned.

- Scott
Logged

North Yorkshire, UK
Offline Offline
Faraday Member
**
Karma: 104
Posts: 5531
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

This could get confusing...

Biocow, Cowjam, Cowman...
Logged

Pages: [1]   Go Up
Jump to: