Go Down

Topic: Arduino and GPS (Garmin Etrex H) (Read 2607 times) previous topic - next topic


Apr 10, 2011, 07:05 pm Last Edit: Apr 10, 2011, 11:32 pm by Eluxiver Reason: 1

I have a problem with connecting my Etrex GPS to my computer using the arduino FTDI chip as a serial to USB device.
I connect my Etrex with a max232 inbetween to my arduino TX and RX pins and i run a very simple sketch so that there is no interference with the chip:

Code: [Select]
void setup()
void loop()


This works and I can get different types of GPS data in the serial monitor.
But the problem is that I want to use a different program (like EasyGPS or GPSbabal) to upload and download waypoints and stuff from my GPS. But this doesn't work! Does anybody know why? The serial port works because I get data but I can't seem to send any to get other stuff like waypoints. I've tried it also with removing the Atmega chip and it's still the same (I still get data with the serial monitor but no connection with another program). Does somebody have an idea??



I thing I have a solution but I don't know how to implement it. Maybe I need to use an extra power source to get to 12V ? Now I'm using the arduino as a power source (5V). I don't know how to connect a extra power source to a Max232, or can this even be done? Like with an extra battery to get a 10-12V output to my GPS.

This is the circuit I'm using:

Anyone an idea?


Maybe I need to use an extra power source to get to 12V

No.  One of the things a MAX232 does is to generate the RS232 voltages.  Assuming you've got power and ground connected as well, your schematic looks correct.



You can always connect external power, but make sure the ground pins are connected together and don't mix up the positive powers.


Just looking at your MAX232 schematic and AFAICT you will want to swap pin 11 to TX and 12 over to RX.
This post may also help


Go Up