Go Down

Topic: Arduino looses port 3 to USB (Read 535 times) previous topic - next topic

We use on our school multiple computers\laptops to play with Arduino. Now one of the laptops has a problem.

When we start Arduino and load a program we get port 3 to use with the USB and thats fine. When we load another program within Arduino we get an error that portal 3 is in use and we cant get another port.

hope someone can help us,

regards
Eljo

mowcius

What OS is this on?

Have you got the serial monitor open in another program perhaps?


What OS is this on?

Have you got the serial monitor open in another program perhaps?


Could you explain what the "serial monitor" is and how to check and change this?

mowcius

Have you got another instance of the IDE open while trying to upload?

You'll have to be more specific about what programs you have open while having these issues and what kind of other hardware you have plugged in at the time (bluetooth devices etc are known to cause issues).

Also, what code did you upload to the board the first time or does this not make any difference to the issue?

Nick Gammon


Could you explain what the "serial monitor" is and how to check and change this?


In the Arduino IDE (GUI program) there is a Tools menu. Under that is Serial Monitor. It lets you see what is going to/from your Arduino via the serial port on pins D0 and D1.
Please post technical questions on the forum, not by personal message. Thanks!

More info:
http://www.gammon.com.au/electronics

Go Up