Go Down

Topic: Digital clock with 3 nos SAA1064 (Read 184 times) previous topic - next topic

Mogaraghu

Dec 07, 2018, 12:57 pm Last Edit: Dec 07, 2018, 12:59 pm by Mogaraghu
Of course its kind off obsolete tech we are talking here … the SAA1064. But then that is the one which packs so much punch / easy to use / HV capability and more than anything I have many to spare !!

I have driven it successfully with 2.3" CA display following a tip in of the recent threads.

But now my requirement is to drive 3 sets of displays and with different Vf voltages for each set of displays. I have made a sketch... just wanted to know what could be the size of the pull up resistors when I am driving this with a MCU which has no in built pull up and runs off 3.3V.

just wanted to make sure before going for the PCB..

PaulRB

#1
Dec 09, 2018, 04:09 pm Last Edit: Dec 09, 2018, 04:21 pm by PaulRB
You mean R1 to R6? They are incorrectly placed, and you need only 2, not 6. 3K3 is a good value.

Pull-up resistors are connected between a pin, or a number of connected pins, and 3.3V (in this case) not the 5V line. So you should remove R1 to R6 from their current locations and add two 3K3 between the SDA and SCL lines and 3.3V.

Quote
I have many to spare !!
Please send some to me. They are getting very hard to find these days.

PaulRB

#2
Dec 09, 2018, 04:16 pm Last Edit: Dec 09, 2018, 04:19 pm by PaulRB
I found another error. Pin 13 of chip #2 and chip #3 are connected to 5V when they should be connected to 12V, I think.

EDIT: I see that chips #2, #3 drive 1" displays, not 2.3" displays, so maybe 5V is OK, although 12V would also be OK. What is the forward voltage of those 1" display segments?

Mogaraghu

#3
Dec 14, 2018, 06:20 am Last Edit: Dec 14, 2018, 06:21 am by Mogaraghu
@PaulRB.

Sorry about the delay … I was on vacation.  Yes that mistake is a drafting error. Attaching the correct method … I guess this is the right way.  I do hope that pulling up the SCL and SDA lines to 3.3V is OK with the ICs themselves being powered up by 5V and 12V respectively ??


And yes the 1" displays work off 5V as their forward voltage is about 2.1V


Thanks so much !!

PaulRB

#4
Dec 14, 2018, 08:04 am Last Edit: Dec 14, 2018, 08:06 am by PaulRB
You are correct, there is a possibility that pulling up the SDA/scl lines to 3.3V might not work. I have never tried this. You will need to test the circuit. Being quite old, the saa chip may not have been designed to work with 3.3V signals. But connecting the SDA/scl lines to 5V could damage the 3.3V MCU. If your testing shows that 3.3V does not work reliably, you will need a logic level convertor module to translate the MCU's 3.3V signals of SDA/scl to 5V for the saa chips. These modules are easily available and cheap on eBay etc.

Go Up