Pages: [1]   Go Down
Author Topic: avr atmel1284 unprogrammable since today.  (Read 518 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

so this is what is happening:
yesterday i succeded in programming my atmel1284p using the arduino as a ISP. but today i cant program it anymore.
i can still upload a blink program to the arduino, and the atmel1284 still runs the program i have burned yesterday, but today i cant program it. always get the not sync resp 0x00 or respo 0xe0.

i dont know what had happened. i was using the mosi miso sck and reset ports of 1284 ports to receive the program from arduino. the program i have uploaded all the ports to output (DDRB = 0xff) and set them as active (PORTB=0xff). Is this why i cant program it? because MOSI MISO and SCK are located on port B.5 B.6 and B.7.

thank you for your help
Logged

nr Bundaberg, Australia
Online Online
Tesla Member
***
Karma: 121
Posts: 8442
Scattered showers my arse -- Noah, 2348BC.
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

What your program does to any pins won't affect programming. It's more likely you changed a fuse.

Did you manage to program the chip more than once yesterday, or only a single time?

______
Rob
Logged

Rob Gray aka the GRAYnomad www.robgray.com

Offline Offline
Newbie
*
Karma: 0
Posts: 20
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I get the not sync error when I don't specify the baud rate in avrdude. -b 19200 seems to work; is it possible you've changed a programming option?
Logged

Pages: [1]   Go Up
Jump to: