Go Down

Topic: Servo broken? (Read 856 times) previous topic - next topic

cyntrox

Hey, my HD-1440A microservo hasn't been behaving as expected lately, and I was wondering if you could help me diagnose it.

The servo inputs are tree wires; one yellow, one red and one brown. I have, for my test circuit, connected them as follows:








ServoArduino
Yellow wire-Gnd
Red wire-5v
Brown wire-Digital pin 9



I then tried to run the "sweep" example that comes with the Arduino software. The servo went to its farthest counter-clockwise position and remained there. If I put my finger on it, I could feel it vibrating slightly.

Is there anything else I can do, or will I just have to declare it dead?

AWOL

Isn't the yellow the signal wire, and brown the ground?
"Pete, it's a fool looks for logic in the chambers of the human heart." Ulysses Everett McGill.
Do not send technical questions via personal messaging - they will be ignored.

cyntrox

Yes, you're right. I wish they were marked... Oh well, thanks! It works now.

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy