Go Down

Topic: cant change serial port!! please help soon (Read 2 times) previous topic - next topic

James C4S

Quote
try and download the "blink" sketch, it will load for 5 seconds then say "Serial port "Com1" not found"

The 5 seconds is the IDE compiling the sketch and then trying to load.  It doesn't take more than 1 second for the Uno to get updated with the Blink sketch.


Quote
i look through files and found out my arduino is on Com4.

What files did you look at?  The only place you can determine what com port the Uno gets assigned is in the Device Manager.  Verify that when you plug in the Uno it shows up on the Com Port devices (in Device Manager.)
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

j7frostbite

yup i looked at the devise manager, I believe it said Arduino(Com4). but is there anything I can to to change it? thanks for the help James

Nick Gammon

When I was mucking around yesterday booting Windows in "safe" mode, the Serial Port menu item became greyed out. Therefore I assume that the driver is not (fully) installed. Did you install the device driver as instructed?

You can directly edit the preferences.txt file (see the IDE preferences for its location). Once you have found the location, close the IDE, look for COM1 and change it to COM4. Save and restart the IDE.

However I found that even doing that did not help if the driver was not installed.

j7frostbite

the computer is running in safe mode so thats probley why its greyed out then... thank you so much!

Nick Gammon

Better add that to the list, Site Administrators, to not attempt to use Arduino when booting Windows in Safe Mode.

Go Up