Go Down

Topic: WiFi Reconnect returns WL_CONNECT_FAILED on successive connection attempts (Read 124 times) previous topic - next topic

Bjain

Hello,

I had a MKR1000 that has been connected to WiFi Since past 1 week. yesterday on 10th January, 2018 at 5:00 p.m. its connection got interrupted and ever since its unable to connect to WiFi.

On repeated attempts to connect it to WiFi, its returning the WL_CONNECT_FAILED output.

What are possible reasons for connection failed and how can I overcome this problem and find a permanent solution without resetting the MKR1000.

As resetting the MKR1000 causes all the data stored to be lost which has not been transferred to server.

ballscrewbob

You will have to at least try the reset button.

As for why it has not re-connected it is a little hard to say.
Useful things would be a copy of the sketch and knowing if you have the latest firmware.

It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

Bjain

Yes I have the latest firmware.

Using the reset button is not the solution as it erases all the previous data stored which has yet not been transferred to server.

ballscrewbob

One way or another a RESET will be involved.

If you de-power it the data will be lost.
If you upload a new sketch the data will be lost.

As it stands there is little you can do at this moment to prevent that and little else I can offer by way of help.

The sketch will not be lost as that remains on the MKR regardless.

I wish you luck but doubt there will be any easy solution to your dilemma.

It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

Go Up