Go Down

Topic: PSXLibrary Problems (Read 772 times) previous topic - next topic

aeemnrsu

so I downloaded this library from http://arduino.cc/playground/Main/PSXLibrary and unzipped it in ~/arduino-0021/libraries/
I just tried loading the library in the following code:
Code: [Select]


#include <Psx.h>

void setup() {
}

void loop() {
 
}


and I couldn't get it to work and I got this error:
Quote


In file included from C:\Programs\arduino-0021\arduino-0021\hardware\arduino\cores\arduino/WProgram.h:6,
                 from Dualshock.cpp:4:
c:/programs/arduino-0021/arduino-0021/hardware/tools/avr/lib/gcc/../../avr/include/math.h:439: error: expected unqualified-id before 'double'
c:/programs/arduino-0021/arduino-0021/hardware/tools/avr/lib/gcc/../../avr/include/math.h:439: error: expected `)' before 'double'
c:/programs/arduino-0021/arduino-0021/hardware/tools/avr/lib/gcc/../../avr/include/math.h:439: error: expected `)' before 'double'


I tried googling the error but I can't find a proper fix.

Go Up