Pages: [1]   Go Down
Author Topic: IDE scrolling bug  (Read 586 times)
0 Members and 1 Guest are viewing this topic.
Connecticut
Offline Offline
Edison Member
*
Karma: 16
Posts: 1216
RTFD (Datasheet in our case)
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

There is a problem with the Arduino IDE on Mac OS X (it seems to also happen on Processing, so maybe they should know, too) that if you type a line of code larger than the width of the window (a single line comment, maybe) a horizontal scroll bar will appear, as one would expect. But if you scroll to the right to view the end of the line and then scroll back to the right, the small default margin is gone, with the code pushed right up against the edge of the window.
I have attached a normal window and the buggy window.


baum


* normal.png (35.05 KB, 580x680 - viewed 11 times.)

* bug.png (39 KB, 573x681 - viewed 13 times.)
Logged

Global Moderator
Netherlands
Offline Offline
Shannon Member
*****
Karma: 168
Posts: 12428
In theory there is no difference between theory and practice, however in practice there are many...
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

What happens if you do a ctrl- t  (autoformat) as it redraws all? does it help?
Logged

Rob Tillaart

Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -
(Please do not PM for private consultancy)

Connecticut
Offline Offline
Edison Member
*
Karma: 16
Posts: 1216
RTFD (Datasheet in our case)
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Nope. Still up against the edge.
Logged

Pages: [1]   Go Up
Jump to: