Pages: [1]   Go Down
Author Topic: Setting defaults in eagle  (Read 2007 times)
0 Members and 1 Guest are viewing this topic.
South East USA
Offline Offline
God Member
*****
Karma: 5
Posts: 654
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I can't seem to load the web based forum for eagle cad.  Does anyone know how to set some of the defaults.  Everytime I start up, I have to change the grid to .1 inch, (and turn it on), and change the tplace layer color so I can see it...
thanks.
Logged

SF Bay Area (USA)
Offline Offline
Tesla Member
***
Karma: 134
Posts: 6760
Strongly opinionated, but not official!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Eagle will start off by executing the "eagle.scr" script from the library path you have configured in the "directories" option.  You can have this do customization, usually by calling additional scripts.  For instance, mine looks like
Code:
# Configuration Script
#
# This file can be used to configure the editor windows.

BRD:

script billw-brd.scr;

SCH:

Grid Default;
Change Width 0.024;
run classes;
script billw-sch.scr;
Some stuff is remembered elsewhere.  There is (on unix-like systems) a $HOME/.eaglerc, for example (not designed to be user-editable, exactly.  Contains lots and lots of undocumented option settings.)
I THOUGHT that color definitions were remembered in there and were "sticky" without the user having to do anything special.  If you're losing your special color settings, you might have some mis-configuration that prevents them from being saved.  (OTOH, I always end up seeing the arduino team's color choices when I look at one of their reference designs, so this may be saved in the individual design files as well.)
Logged

Pages: [1]   Go Up
Jump to: