Go Down

Topic: Can't upload sketch on Uno (Read 660 times) previous topic - next topic

AmirBGU

compiles blink fine, but when upload to I/O board i get:
Binary sketch size: 1108 bytes (of a 14336 byte maximum)


avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51


this is on vista 64 bit

its getting power and the LED which is connected to pin 13 is blinking
The driver looks ok, when I go to Tools-serial ports it points to port3
And the board is not hooked to nothing except the USB

Thank you

Coding Badly

Close the Arduino IDE.  Disconnect the board.  Start the Arduino IDE.  Which serial ports are listed under the Tools menu?

Nick Gammon

Did you install the device drivers?
Please post technical questions on the forum, not by personal message. Thanks!

More info:
http://www.gammon.com.au/electronics

AmirBGU

Hello
windows vista automatically installed the device drivers via the web.
and what do you meen by "Close the Arduino IDE"?
and there is onely one port listed under the Tools menu
that is port3

Thank you.

Coding Badly

windows vista automatically installed the device drivers via the web.


It is very unlikely Windows installed the correct driver.  Step #4...

http://www.arduino.cc/en/Guide/Windows
http://www.arduino.cc/en/Guide/Windows#toc4

Quote
and what do you meen by "Close the Arduino IDE"?


If the IDE is running, click the [X] in the upper-right corner to close it.

Quote
and there is onely one port listed under the Tools menu that is port3


The driver is not installed.

AmirBGU

it works
Thank you for your time

Go Up