Go Down

Topic: HD44780 Doesn't Reinit After Power Off/On (Read 3995 times) previous topic - next topic

liudr

Great! Let me know if you have any questions on my libraries or hardware.

gerschu

By the way, i had a similar issue with no reset after power off, using photoduino board with the uno.
I cut the bridge at reset-en on board, voila : solved

palitu

Hey, i posted this on adafruit just now, but though i would share the love for anyone searching:

Hey,

I have quite a bit about this issue, and haven't really found an explanation or proper solution.

I am using a freeduino leonardo,and read somewhere that the LCD needs ~15ms prior to it being initialised. To fix it, i simply put a delay in the setup() function.

haven't had an issue yet.

Code: [Select]
void setup() {
    delay(20);
    lcd.begin(16, 4);
}

floresta

You have resurrected an ancient thread for this non-news.

Quote
I am using a freeduino leonardo,and read somewhere that the LCD needs ~15ms prior to it being initialised. To fix it, i simply put a delay in the setup() function.


I wonder if that is why the LCD initialization in the library starts out with a 50000 uS (50 mS) delay?  You haven't 'fixed' anything with that added delay unless you have an extremely out-of-spec display.

You should be more concerned with the improper cursor positioning on lines 3 and 4 of the 16x4 displays.


Don

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy