Pages: [1]   Go Down
Author Topic: Adafruit MotorShield  (Read 632 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hey! Has anyone tried the adafruit motorshield? Well, I did! I got it for Christmas, and it totally didn't work! Whenever you tried to turn it on, It acted like a stepper motor! It just gave a pulse, and then stopped! Well, I think my dad and I found out the problem. It had anti-current protection. At least, too much!!! It thought it was drawing too much current, but it really wasn't! Well, there's three chips in the motorshield. Two are what actually does the driving, the other is just an interface, and that was what had the anti-current protection! So, I just pulled out the chips, forgot the board, used the chips, and it worked!



www.sulzenstudio.webs.com
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I just made one myself and it worked with no problems. I would go over the build and check the placement of the components and connections.

I highly suggest a go to the Adafruit Forums and make a post under the Arduino Shields Section . They are very helpful.

http://forums.adafruit.com/

Also you can send an email to them at  Support@adafruit.com or via http://www.adafruit.com/support .

Just don't give up.

smiley

If all  fails they might end up replacing it for you.  

Kevin Groce
« Last Edit: April 30, 2011, 11:39:21 am by Nashblackcat » Logged

New Hampshire
Offline Offline
God Member
*****
Karma: 17
Posts: 781
There are 10 kinds of people, those who know binary, and those who don't.
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

You may want to read this: https://docs.google.com/View?docid=dgwf6cmm_2fznx7qgr&pli=1

There's nothing wrong with the design of the motor shield as is.  The only current protection on the shield is for the serial/parallel shift register, and that is because that is a low current IC.  Without seeing the code you used, I can't say for sure, but the behavior you described sounds more like incorrect programming that a hardware problem.
Logged


Pages: [1]   Go Up
Jump to: