Pages: [1]   Go Down
Author Topic: avrdude: stk500_getsync(): not in sync: resp=0x30  (Read 1632 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I am getting the following errors when trying to upload the blinking led example on my board (Arduino Duemilanove with the ATmega328).

avrdude: stk500_getsync(): not in sync: resp=0x30
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

I have used this board before and was able to load code onto it with no problem so I am guessing I have my environment setup correctly and the correct bootloader is on. The arduino connects on com3 in the arduino ide. In my computers device manager though I do not see any com3. This is making me guess the arduino has a problem. I removed the ATmega328 microcontroller from the board and connected the rx pin to the tx pin and tried sending data through the serial terminal, but there doesnt seem to be a loopback.

Any other suggestions on what I can do?

Thanks.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I had the same problem with my Uno. I first check it on annother computer, OK. Tried everything I could get in forums but no joy.
Uninstalling WinAVR solved the problem. Can not tell why but it did. Have not installed WinAVR again.
Logged

Offline Offline
Sr. Member
****
Karma: 0
Posts: 298
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I had the same error as well, and you can try clicking the reset button right after it says " binary sketch uploaded..." and you can try clicking reset just before, as soon as you power the arduino etc.

Keep pressing reset as different time as my problem was solved by pressing reset right after the arduino is powered.

Hope this helps.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi guys,

I'm using Arduino UNO,Arduino-0022(IDE version) and Windows XP. To solve this issue, try this method

1. Go to  \arduino-0022\lib\preferences.txt
2. Change this line "serial.debug_rate=9600" to "serial.debug_rate=4800"
3. Save this file.

Make sure you have selected the correct COM port(Tools->Serial Port) and correct board(Tools->Arduino Uno). Then you can compile your sketch and upload to your board.

Good luck! smiley
Logged

Pages: [1]   Go Up
Jump to: