Go Down

Topic: XBee Pro S2B in AT mode keeps resetting the Arduino (Read 5 times) previous topic - next topic

stuBee

I have just bought a whole bunch of Xbee Pro S2Bs and Freetronics Eleven boards.

When I set up the XBees in AT mode, the Arduino constantly resets.  At least that's what I think it is doing - the D13 LED keeps flashing (3 times in quick succession, once per second) and the sketch won't run.

In API Mode it seems fine, but I want to use AT mode for simplicity - anyone have any ideas why AT mode would be causing the Arduino to reset?

Jack Christensen

Difficult to speculate without a schematic and the code for the Arduino sketch.
MCP79411/12 RTC ... "One Million Ohms" ATtiny kit ... available at http://www.tindie.com/stores/JChristensen/

stuBee

Hi thanks for the reply - I should have said that regardless of the code on the arduino the same thing happens.

If I get a new Arduino and Xbee out of the box, configure the XBee to End Device AT and plug it into the Ardunio via shield with external power, the D13 light does the flashing and the sketch won't run.  (Would be the 1 second D13 on/off sketch by default)

So I think it's independent of code and I am using the standard sparkfun XBee shield.

I have seen one other post with the same issue but no solution was given here:

http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1288221937

markbee

XBee Pro S2B programmable? Maybe thats something conflicting with the Arduino?

Jack Christensen

If the shield is taken off, all is well?  Sketches can be uploaded and they run OK?  If so, do you have another shield you can try?  Have you tried the shield both with and without the XBee?  Any chances of soldering issues?  Running out of ideas, sorry.
MCP79411/12 RTC ... "One Million Ohms" ATtiny kit ... available at http://www.tindie.com/stores/JChristensen/

Jack Christensen


XBee Pro S2B programmable? Maybe thats something conflicting with the Arduino?


I've only used the low-power modules.  What are you using for a power supply?  Any chance the higher power requirements of the Pro module is causing a "brownout"?
MCP79411/12 RTC ... "One Million Ohms" ATtiny kit ... available at http://www.tindie.com/stores/JChristensen/

stuBee

Hi Jack,

Yes the sketch works fine as soon as I take the XBee off, and I have tried several shields/xbees/arduinos. I am also using external power so I don't think that should be a problem.

Does work in API mode but I am going to have to change alot of code to get that to work - which I would like to avoid!!

Actually one more strange thing is that it seems to work OK (even in AT mode) on a Twenty-Ten but I need it to work on the Eleven's I have bought.

Thanks for your replies!!

Jack Christensen

Yeah sorry, I'm not familiar with the Freetronics stuff either.  I especially can't figure why API vs. transparent mode would make a bit of difference, especially with the Blink sketch!

Do you have a low-power XBee you could try?  Just shotgunning here...
MCP79411/12 RTC ... "One Million Ohms" ATtiny kit ... available at http://www.tindie.com/stores/JChristensen/

stuBee

Low power ones work fine too. Just that I have got a bulk order and they are all the Pro S2B models.

Is the S2B necessarily the "programmable" type do you know? I am wondering if I should send back the ones I have bought and get the "non-programmable" ones.

The modem type shows up as XBP24BZ7 in X-CTU.

stuBee

Does anyone know much about the S2B models?

The modem type shows up as XBP24BZ7 in X-CTU.

draythomp

I've seen this kind of problem caused by two different things.  1.  The reset line from the XBee to the rest of it didn't have a pull up resistor on it and it was floating across the point where things reset.  2. When the XBee transmitted it sucked the power way down and reset the entire system.  The pro versions suck a lot of power in a short amount of time.

The solution to the first problem is a pull up resistor added somewhere.  The second problem is a large capacitor placed on the power near the power to the XBee to discharge and keep the voltage up when transmitting.

The three flashes make me think that the XBee is pulling power down during its commissioning to the coordinator process.

At least it's something to try.
Trying to keep my house under control http://www.desert-home.com/

Go Up