Pages: 1 [2]   Go Down
Author Topic: Something else (where's the Arduino, should I call him Waldo???)  (Read 1935 times)
0 Members and 1 Guest are viewing this topic.
Canada
Offline Offline
Newbie
*
Karma: 0
Posts: 11
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

It gets better, (or worse), this morning I decided to check the emails etc. and just for the heck of it I unplugged all devices from my computer (the 7) except the Uno, & when it came out of hibernation lo and behold the Uno showed up in my device manager with all drivers installed correctly, alright!, so I rewired the blink light as per instructions (the first cct in the book, 1 diode and 1 resistor, 3 wires) and modified it to flash on for 2 seconds and off for 1, I compiled it and I downloaded it to the Uno (on com port smiley-cool and IT WORKED!
So then I tried to make the program a touch longer (cut and paste and change times for a random look) I compiled and went to download it and the Uno had gone, it said com 8 no could not be found use com 3, no communications.
I tried all the same steps again ( and again and agin) with the Uno plugged in and the Uno unplugged and got nothing, once again it has dissapeared from both the 7 and the XP, it is however working in "modified blink", but again now I cannot do anything with it! Frustrating or what?
What do you think?
Logged

Portugal
Offline Offline
God Member
*****
Karma: 6
Posts: 962
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Did you installed the UNO .inf file or the FTDI drivers?
Logged

Swannanoa, New Zealand
Offline Offline
Full Member
***
Karma: 1
Posts: 202
New To Arduino (and C)
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Dave
I suspect that there is a driver somewhere that it taking over your port (or the computer thinks it is)

There is a program called Portmon under the windows SystemInternals suite. (Its also available seperately elsewhere).

This may show up whatever is trying to steal your port.

Out of interest you said you unplugged all the devices connected.
Just what is connected. ?
Is there a usb modem, or printer connected that you unplugged.? (HP have a usb monitor program).
More importantly, is the UNO being plugged into the actual box, or via a hub (which is what the usb ports in the screnn are).

At least its a step forward.
mark
« Last Edit: May 05, 2011, 02:42:25 pm by markB » Logged

Canada
Offline Offline
Newbie
*
Karma: 0
Posts: 11
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi Mark,
I am working (and Arduino-ing) right now, I tried to find Portmon, on my laptop but so far no luck.
Plugged into the laptop is a wireless mouse, a HP printer (sometimes) and a wireless internet connection stick (I live in the country and that is the best / fastest / most affordable option), thats it, no USB hubs or anything. The Uno goes straight into the laptop usb port.

Bear in mind that I plugged it into the other computers, the one with XP did nothing (there is nothing at all on the USB system, even the keyboard and mouse are the old school plugs, and the computer has been reformatted and is basically as it was when it was new, there isn't even an internet connection to it. I put the unzipped Arduino 0022 into it from a flash stick via the USB port) and the other windows 7 laptop did nothing either when it was plugged in there either.

I will try and figure out which driver was installed, I pointed it to the drivers folder and it selected what it wanted to use, then worked once, then stopped, and now I cannot pull up the device on the computer to check on drivers................
As this is my first entry into dealing with the "non mainstream" parts of the computer I have a lot of catching up to do to get close to most of the other guys on here, so please be patient! Everyone has to start somewhere, I am fairly technically minded, so hopefully will start to catch on fairly quickly, we'll see.
Logged

Swannanoa, New Zealand
Offline Offline
Full Member
***
Karma: 1
Posts: 202
New To Arduino (and C)
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Dave
I did see that you did have it plugged into other machines.
Regardless of whether Arduino is on the computer or not, it should still try to install a driver.
I was finding that despite the computer not talking, it did show a USB device plugged in on the task bar, and the UNO was in device manager.
In device manager you can choose to show hidden items under the view menu.
The other thing is if you click on each of the USB Root Hub icons, and click the power tab, it should show 100mA assigned to the device

I'm assuming that you have an USB icon on the task bar (when its running), so if you were to try applying sideways/up/down pressure to the USB cable at the socket end, it may show up as disconnected/connected to at least isolate a faulty socket/joint.

BTW you can run Arduino straight from the memory stick, it doesn't need to be installed (except the driver).

Portmon is not part of the operating system, you can download it from http://technet.microsoft.com/en-us/sysinternals/bb896644 or the whole suite of utilities from http://technet.microsoft.com/en-us/sysinternals/bb842062 (they do interlink on the page).
Procmon (in the suite) is something that shows what process is running, but be warned 10mins generates some 60-75,000 items.

The fact you tried it on a number of other computers without it asking for the driver, still makes me think you have a board issue.
However its going at the moment, so enjoy, and maybe let your supplier know.

We all have to start somewhere, but the internal workings of Windows wouldn't be the first place I would have picked.

Mark


* USB Root Hub.jpg (12.9 KB, 302x138 - viewed 11 times.)
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I think I have the answer. I was having almost exactly the same problem. Then I remembered that the power pins on the USB cable touch before the RX TX pins do. It turns out I hadn't inserted the USB cable all the way into the Arduino Uno USB socket. Once I did so, I heard the USB device installation noise and was able to install the drivers as per the instructions. Now I seem to be working fine.

I hope this helps.

Ray
Logged

Canada
Offline Offline
Newbie
*
Karma: 0
Posts: 11
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks guys, following all of your advice I played with it on the xp computer last night, it wouldn't work (still) so I left it plugged in and turned off the computer. This morning I turned it back on and the Uno showed up in the uninstalled hardware (don't know why, I tried booting up before with it plugged in). I was VERY careful about which driver I installed, to the point where I actually deleted the FTDI driver folder altogether to make sure I didn't get it wrong. I was having trouble identifying the inf driver, all I found was a notepad type file..........
Right now it is working and I can install programs, (modified blink, yehaa!) on my XP machine, I am very happy, later I will tackle the 7 machine.
I think it was plugged in all the way, but I will be checking that more carefully in the future too


You guys are awesome, many thanks for all your help.
Now I can start to play & learn, should be fun............ smiley-cool
(& hopefully it will keep working, I am a little scared to unplug it from the xp right now! smiley-sweat
Cheers
Dave
Logged

Swannanoa, New Zealand
Offline Offline
Full Member
***
Karma: 1
Posts: 202
New To Arduino (and C)
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Dave
Most hardware leaves the usb port powered up, even during a reboot (unless you set it in bios).

I think we need to include the instruction "remove the power from the computer, inc battery on a laptop" as a hint if you can't get the pc to recognise a new device.

The inf files are a plain text file. Once you get the hang its not too hard to read them.
Heres what I found out during my adventures.

The attachments will help, these are from my computer and yes the UNO is using the Freetronics driver (its the same)
You need to identify the VID_xxYYzz...&PID_xxYYzz... numbers, within the driver .inf you made windows install. (You can also search each usb device)

Open up Regedit (Start Run type in regedit and press enter).
Under EDIT there is a find option, so enter the VID&PID (in this case Vid_2341&Pid_0001) (see Regdit.jpg attachment)
It should be in HKey Local Machine System ControlSet001 Enum USB (Note this sometimes get abbreviated to HKLM \ System \ControlSet001 ..etc)
There is enough english words there to work out this the one you're after.
The Device parameters shows which port it will use.
Copy the ClassGUID (easiest way is double click it, and then copy with Ctrl and C (very useful to remember as its an underlyingwindows function).
Click My computer at the top so that the search starts from the top, and then EDIT find and paste by Ctrl and V. Hit the find next.
It should bring you to HKLM ControlSet001 Control Class (see Regedit2.jpg)and if you open up the entry there a series of numbers which should match the port number. In my case it installs as Port 4.

So you've identified the device, and found out where windows hides its info, but what does it mean.
Well ....  InfPath contains an oemxxx.inf, which is a copy of the driver you pointed windows at. (Or it thought it would use)
oemxxx.inf gets loaded into C:\WINNT\inf (or C:\Windows\inf) for XP.
Note this is a system directory and is often hidded. You can force Explorer to go there by typing it at the top.

If you were really keen to make windows ask for a new driver, you can make the oemxxx.inf go away by adding old_ to the front.

NTMP states it uses usbser.sys to talk which is the same in XP and 2K (not sure for the rest).
You can look at this to verify the version. It resides in C:\WINNT\Sytem32\drivers (or C:\Windows\System32\Drivers in XP)
There have been some fixes for the XP version, and in my case I loaded the newer one into Win2k (it didn't even complain).

Hope this helps someone, as i iknow how frustrating it can be, I spent at least 80 hours to sort mine out.

Mark




 




* Regedit.jpg (134.34 KB, 1577x1046 - viewed 12 times.)

* Regedit2.jpg (106.55 KB, 1196x824 - viewed 9 times.)
Logged

Canada
Offline Offline
Newbie
*
Karma: 0
Posts: 11
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi Mark,

You know what, when I get the chance this weekend (it's Mother's day weekend with all that entails) I will follow this step by step on the windows 7 laptop and will let you know what happens.

Then maybe I can give the kids the XP computer like I was suppossed to before I had to experiment with it! But once I get into the Arduino and understand it then I really want to teach them early so this stuff comes easily to them, I have been looking through the 12 projects in the book and once each one is understood there are all kinds of applications we can play with by combining different parts.

Watch this space for the results of the top paragraph.

Cheers, smiley-grin

Dave
Logged

Swannanoa, New Zealand
Offline Offline
Full Member
***
Karma: 1
Posts: 202
New To Arduino (and C)
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Understood.
Not sure how Windows7 does it, I haven't progressed to it, as new motherboard, ram and power supply reqd.
i also don't relish the thought of spending a week or more installing the multitude of programs I have on this one.

send me an email m(dot)beckett(at)paradise(dot)net  (no nz, you know what to swop but the trolls don't)
I have a number of links for tutorials I can send.

I would get into an LCD quickly, much more feedback than just lights.
The DS1820B temp is also good as its instant feedback.

I also have a simple robot project that would transfer to Arduino easily.
You could also check out Hannos 12blocks. He resides in chch, and its very clever. Works with picaxe, parallex, arduino, basic stamp and some others either as graphical or text. http://12blocks.com/.

He had 6/7 yr olds making thing work in 10mins using it.

Cheers
Mark
Logged

Pages: 1 [2]   Go Up
Jump to: