Go Down

Topic: Something else (where's the Arduino, should I call him Waldo???) (Read 2249 times) previous topic - next topic

Hi Guys,
Yes another new guy on the block, and I have looked all over for relevant posts with no luck so far, I skipped some steps too and this made no difference, so here goes.
I have a brand new Arduino Uno from Solarbotics, in the ARDX package, it has an ATMEGA328P chip in it.
I downloaded the latest verion of Arduino software (0022) drivers and went to work.
On my laptop (Windows 7) I followed all of the instructions and plugged the Arduino into my USB port and it lit up (power, awesome) and the light attached to pin 13 (on the board) went into blink mode (fantastic) and......................well thats it! I have been trying for 4 days (not quite steady, but any spare time) to get some form of response from it, I have now tried plugging it into 3 different computers, two with 7 and one with XP, and 2 different USB cables and each time it does the same procedure, but when I try and look for it in devices / hardware /device manager / usb ports / other and all the different places I have read to try the thing does not show up.
What I have basically ended up with is a blinking light and an on light on a USB port. I cannot install device drivers as there it does not show up as a  device on any one of the three computers (for a total of 10 USB ports) or two usb cables, windows does not seem to accept that it exists.
Any suggestions would be greatly appreciated, this thing looks like a fun and useful tool and I want to get my kids working with it asap. I am sure I am doing something (or not doing something) simple, but from all the stuff I have read you plug it in and it will appear somewhere.
I also tried uploading to the Arduino and ended up with avrdude:
stk500_getsync ( ) : not in sync: resp=0x00
avrdude:stk500_disable (): protocol error, expect=0x14, resp=0x51
I looked up these codes and they are apparently very generic to the Arduino, please help!!!!! THANKYOU in advance.  :~


Coding Badly

Quote
On my laptop (Windows 7) I followed all of the instructions


URL?


markB

Whathappensif

To me it sounds like the UNO is faulty.
I presume you don't have it resting on a conductive surface, which shorts out the USB pins.

The fact it doesn't even ask for drivers, means it isn't communicating.
The blinking LED is a preloaded sketch in the controller.

You have already tried multiple USB ports, different OS, USB cable and computers.

It should ask you for the driver, and show in the device manager as either good or faulty.

Don't suppose you have access to another user, to verify it before contacting the supplier.

Mark

Okay, I think I figured out what you meant (sorry, this thing has addled my brain) URL was http://arduino.cc/en/Main/Software
I understood that was where the latest and greatest was supposed to be.

Hi Mark,
No, it is mounted on the fancy non conductive board from the supplier (it is an experimenter kit designed for people who are just learning, like me) and comes with a breadboard and some wiring and components to keep it simple (lights, a motor, a servo etc, actually pretty awesome for a starter).
Unfortunately I don't know anyone else around who may have one, I only found out about them from the instructables pages, so I don't think that is an easy option, good idea though.
Dave

Coding Badly

In that case, I'll assume you made it here...
http://www.arduino.cc/en/Guide/Windows

In which case you need to pay very close attention to "4 | Install the drivers".

markB

Codingbadly
I think you may have missed this bit in the original posting

Quote
I cannot install device drivers as there it does not show up as a  device on any one of the three computers (for a total of 10 USB ports) or two usb cables, windows does not seem to accept that it exists.


He also indicated an XP machine which will definately ask for the driver.

If it doesn't show as a device, windows can't/won't try to install anything.

Thanks
Mark

williamkoepp

i myself just got the ARDX kit from solarbotics. I use a windows based PC (7), install ran perfect for me. i've worked on other boards before. It does sound like the USB connection is faulty. One way to check is plug the USB into the board(do NOT have the battery pack connected that came with the kit), make sure USB is fully inserted. If there is power to the board and it turns on then it is not the USB port itself. If you are unable to get your board working, you can bypass the USB but if you dont have any experance with electronics/breadboards,ext..then i would just send it back to solarbotics for a replacement.
"I,Robot."
"Well I,Tarzan!"

markB

williamkoepp
Good suggestions but you might have forgotten that the USB cable has 4 pins. two for power and two for data.

When the UNO is plugged in, the RX and TX lights should flash brielfy. This is when it communicates to the machine, and the machine trys to identify what it is, so that it can then use the right driver that matches its Vendor ID and Part number.

It pretty quick but should happen each time.

Mark

Ok, I tried the board (again 2 different computers and operating systems and two different USB cables, and I tried wiggling the USB cable and plug gently, but no change) and the TX and RX lights do not flash at all at any time when it is plugged in, unplugged or when I try the reset button. The green power light comes on steady and the "L" light blinks in what I would guess is a meaningful type of code,(it ends up going into a steady blink, and has just turned on steady) but no TX or RX lights at any time, and still not "seen" by either computer................does that help?
Thanks very much by the way, I am having to come and go from the computer, but following as closely as I can, I appreciate the help and hopefully will be able to do the same for others eventually.
Cheers
Dave

Coding Badly

When you connect the Arduino, does the computer produce the "USB device insertion" sound?

With Device Manager running, when connect / disconnect the Arduino, does the list refresh?

No sound, and no refresh when I unplug or plug in the Uno on the windows 7 with the device manager running. I also double checked with my mouse on two different ports (the ones I am trying the uno in) and I do get the sound and the refresh each time I plug it in or unplug it, just not with the uno. I am still trying to figure out how to get into device manager equivilent in the XP machine (it's been a while). but would anticipate the same results.

Got device manager on the other one now (the xp) and as expected the results are as before. I tried a new flash drive on it and all the found new hardware bells and whistles came up as normal...................but nothing with the Uno (or should that be oh no?)
Dave

markB

Dave
There was a series of advertisements here fromToyota. Mainly the Hilux Pickup.
The common theme was a series of misadventures, including a dog that missed the deck as it drove off.
Not sure if it ever got past NZ or Australia...

The expression was 'Bug..r"

It seems to fit here as well.

Looks like its a return to the supplier.

Mark

Go Up