Go Down

Topic: 1.9 Installation (Read 290 times) previous topic - next topic

Docara

Mar 13, 2019, 10:13 am Last Edit: Mar 13, 2019, 10:37 am by Docara
Hi,

I am building a Marlin V2.0 based CNC machine and the designer has provided a custom firmware.
Marlin's V2.0 Github page states I need to use Arduino 1.9 (beta) to install this firmware on to a Mega2560.

I have uninstalled Arduino 1.8.0 and tried to install 1.9 but it does not seem to install in the conventional way and I cannot find an installer.

How do I install v1.9 without an installer file eg. Arduino-1.9.0.-windows.exe

Thanks

pert

There's no need for an installer. Here's how to use it:
  • If you haven't already, download the 1.9 beta build: https://www.arduino.cc/download_handler.php?f=/ide_beta/arduino-1.9.0-beta-windows.zip
  • Unzip the downloaded file.
  • You can now delete the downloaded .zip file if you like, to free up some space on your hard drive.
  • You can now move the unzipped folder to any convenient location on your computer if you like, or leave it where it is. It doesn't matter.
  • Inside the unzipped folder. You will find a file named arduino.exe. Double click on that file to start the Arduino IDE 1.9.0 beta build. You might find it convenient to create a shortcut to that file and put it in your Start menu.

DmitriKoslov

Hey, I'm doing the same thing (cnc, but RAMBo board) and I seem to be having nothing but problems with the Arduino software... I'm running 1.9.0, and it opens fine, but will not compile the code, and seems unable to see any ports. Arduino 1.8.8 sees the ports, and the board, and both Pronterface and Repetier-Host can see the board, and control it... I can't find any reason for Arduino 1.9 to be unable to see the ports, but I'm kind of a noob... It also reports back a list of errors in compiling that have to do with Github... Any ideas?

pert

Arduino 1.8.8 sees the ports, and the board, and both Pronterface and Repetier-Host can see the board, and control it... I can't find any reason for Arduino 1.9 to be unable to see the ports
I don't know what could cause the problem with the ports. I just tested out the latest version of the Arduino IDE 1.9.0 Beta Build and it recognizes all the ports of the various devices I have connected to my computer. Do you know which USB to TTL serial adapter your board uses (e.g. ATmega16U2, CH340, FT232).

It also reports back a list of errors in compiling that have to do with Github.
I can probably help with this, but only if you post the errors:

When you encounter an error, you'll see a button on the right side of the orange bar "Copy error messages" (or the icon that looks like two pieces of paper at the top right corner of the black console window in the Arduino Web Editor). Click that button. In a message here, click the code tags button (</>  on the forum toolbar) and then paste the error. If the text exceeds the forum's 9000 character limit, save it to a text file and post it as an attachment. If you click the "Reply" button here, you will see an "Attachments and other settings" link.

DmitriKoslov

Ok, awesome... Thanks for the quick reply! So the errors I get that seem to pertain to github:

Code: [Select]
Arduino: 1.9.0-beta (Windows 8), Board: "RAMBo"

panic: interface conversion: error is *exec.Error, not *exec.ExitError

goroutine 1 [running]:
github.com/arduino/arduino-builder.(*ArduinoPreprocessorRunner).Run(0xb23924, 0x12abe200, 0xb23924, 0x1476c000)
/home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/preprocess_sketch.go:129 +0x907
github.com/arduino/arduino-builder.(*PreprocessSketchArduino).Run(0xb23924, 0x12abe200, 0xb23924, 0x0)
/home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/preprocess_sketch.go:69 +0x2a3
github.com/arduino/arduino-builder.runCommands(0x12abe200, 0x12a04900, 0x1, 0x1, 0x1, 0x12a04900, 0x0)
/home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/builder.go:207 +0xc1
github.com/arduino/arduino-builder.(*PreprocessSketch).Run(0xb23924, 0x12abe200, 0xb23924, 0x0)
/home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/builder.go:154 +0xb6
github.com/arduino/arduino-builder.runCommands(0x12abe200, 0x12bf1de8, 0x22, 0x22, 0x1, 0x0, 0x0)
/home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/builder.go:207 +0xc1
github.com/arduino/arduino-builder.(*Builder).Run(0x12a5df0c, 0x12abe200, 0x7d, 0x12a00780)
/home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/builder.go:125 +0xb3a
github.com/arduino/arduino-builder.RunBuilder(0x12abe200, 0x7d, 0x12a00780)
/home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/builder.go:223 +0x29
main.main()
/home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/arduino-builder/main.go:396 +0x72f
C:\Users\Chad\Downloads\arduino-1.9.0-beta-windows\arduino-PR-beta1.9-BUILD-104\arduino-builder returned 2
Error compiling for board RAMBo.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.


As for the ttl, I'm not sure exactly, but I read somewhere we could use Arduino Mega 2560 for something... It's a RAMBo 1.4 board though... Not sure how much help that is...

DmitriKoslov

So I just tested, and this error occurs straight out of the box on my machine... Like I uninstalled Arduino 1.8.8, downloaded Arduino 1.9.0, and just trying to verify/compile a blank sketch, it throws the same set of errors, even after deleting the "additional boards manager URL" in Preferences... Could this be a Windows 8 issue?

pert

I'm going to test your hypothesis that the issue might be related to Windows 8, but it will take a while for me to get that version of Windows downloaded and installed on a virtual machine.

Until then, I have something you can try:
  • Exit all Arduino IDE windows.
  • Under the C:\Users\Chad\Downloads\arduino-1.9.0-beta-windows\arduino-PR-beta1.9-BUILD-104 folder, create a folder named portable
  • Start the Arduino IDE 1.9 beta build.
  • File > New
  • Sketch > Verify/Compile


This will ensure that the Arduino IDE is operating isolated from any influences of previous installations. Do you still get the error after following the above instructions?

DmitriKoslov

Wow... I really hope you know how much I appreciate all the effort you're putting into helping me find a solution for this... I'll try your suggestion after I get my kid to bed... I'd like to note that I took a different approach to testing my hypothesis, and tested downloading Arduino on a different machine that's running Windows 10, but unfortunately still had errors... It found the port, seemed to connect, unfortunately it threw a whole host of new errors... When I get to my computer I will post them... Do people normally have this much trouble getting this to work?

DmitriKoslov

So I just tested your idea, and it doesn't seem to change anything... Just making a folder called "portable" makes the program operate isolated? Anyway, same errors, still no ports... Was there anything else I was supposed to do with that folder?

DmitriKoslov

So... May have an update to the situation... Not sure if it's because of the "portable" folder, but I tried adding libraries, and those didn't work out, either...

DmitriKoslov

Never mind... I deleted the "portable" folder, and the libraries I used to have are now installed again... And again, same errors... Sorry for spamming...

pert

Just making a folder called "portable" makes the program operate isolated?
Correct.

Was there anything else I was supposed to do with that folder?
No. Just creating a folder named portable in the Arduino IDE installation folder and then restarting the Arduino IDE causes the Arduino IDE to run in portable mode.

Anyway, same errors
I'm sorry to hear that. I was not able to install Windows 8 because Microsoft no longer provides a download for that version. I did install Windows 8.1 and tested the Arduino IDE 1.9.0 beta build with that operating system but I couldn't reproduce your issue.

Please do this:
  • File > Preferences > Show verbose output during: > compilation (check)  > OK
  • Sketch > Verify/Compile
  • After the compilation fails you'll see a button on the right side of the orange bar "Copy error messages". Click that button.
  • Paste the error messages in a reply here using code tags (</> button on the forum toolbar).


If the length of the output exceeds the forum's 9000 character limit, save it in a txt file and post it here as an attachment. If you click the "Reply" button you'll see the "Attachments and other options" link.

DmitriKoslov

Ok, so I tried compiling a blank sketch both with, and without a "portable" folder, and the errors are the same, but I'll attach both error messages. I enabled verbose for both. Also, I was unable to install the U8Glib LCD library when running with a "portable" folder...

pert

You're introducing extra variables by using the RAMBo board and trying to install this library. Before even thinking about any of that, we need to deal with is getting the unmodified Arduino IDE to compile. Please do this:
  • Do a fresh installation of the Arduino IDE.
  • Create the portable folder.
  • Start the Arduino IDE.
  • File > New
  • Tools > Board > Arduino/Genuino Uno
  • Sketch > Verify/Compile


Does the error still occur?

Go Up