Go Down

Topic: Processing error message: (Read 1 time) previous topic - next topic

Michael2

Hi everyone. As a relative newbie, I was trying the Learning>Communications>Graph tutorial. Arduino worked fine, but when I tried the processing sketch, it spat out this error message:
         WARNING:  RXTX Version mismatch
   Jar version = RXTX-2.2pre1
   native lib Version = RXTX-2.2pre2
It does not seem to be anything to do with the code I am running. Whenever I try to read Arduino's output, it produces this message, and the code doesn't work.

If somebody could point me in the right direction, or if there's already a forum post about this, then send me there. Thank you.

PaulS

Compiled JAVA code goes in a jar file, with a version number associated with it. The Processing application expects one version of the TXRX jar file. You have a different version.

Which OS are you using?

Michael2

I'm using Windows XP with the latest version of Processing/Arduino. What's OS? (sorry, very newbie!)

PaulS

Quote
What's OS?

O = Operating
S = System

Michael2

Thank you!  :smiley-red: Well, I know now.

Have downloaded RXTX-2.2pre2, and de-zipped it. Where and what do I do with it?

Thanks Paul!

notmuchofaprogrammer

Hi, I am a complete beginner at this and had been stuck on this one for a while and couldn't find anything in the forums to help me (I now realise that I don't even want to use this graph, but as it had defeated me for so long I wasn't going to let that get in the way of things).

I had the same WARNING message as above (in white), but below that in red a whole load of text in red, which included:-

gnu.io.PortInUseException: Unknown Application
   at


...etc

Well, I ignored/didn't notice that useful piece of advice and carried on tinkering, until much, much, later I realised that perhaps if I had the Arduino software Serial Monitor open the Processing software would not be able to read the serial port.  I closed the Arduino Serial Monitor and hey presto all fine.

I had also been trying to solve this problem without the Arduino connected, thinking that 'Run' in Processing was the same as "Verify/Compile" in Arduino - oh dear.

So two very silly basic errors and lessons learned - just sharing this with all the other novices as I couldn't find anything like this in the forum and it may save at least one person some frustration.

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy