Pages: [1]   Go Down
Author Topic: Visual basic 2010 exemple  (Read 1314 times)
0 Members and 1 Guest are viewing this topic.
Portugal
Offline Offline
Edison Member
*
Karma: 37
Posts: 1593
Pretending you know everything then you will learn nothing.
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello all
I need to develop a domotic application to a work of school to end my studies smiley The application must be in VB2010.
I have a arduino Mega for the job and In fighting to find a example of a working project very simple just to see how the firmataVb work.
For reference I was following this http://www.acraigie.com/programming/firmatavb/firmatavb_downloads.html
But I cant run successfully the program since it wont work as simply turn a led on and of
Any help?

Logged

Debian,Mint,Ubuntu
Arduino Mega 2560
Arduino Nano
Arduino Duemilanove
MAC OS Montain Lion
Raspberry PI Model B


Portugal
Offline Offline
Edison Member
*
Karma: 37
Posts: 1593
Pretending you know everything then you will learn nothing.
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

sorry , you are right. My problem is when I hit run on VB, it runs without any error but my arduino board dont responde to clicks made on the program to activate the output leds.
the problem is not in arduino because I had use a firmata_test program(already an .exe file) that I found on the web and it works great with all output and inpouts.
So I was looking for a simple example to just turn on and of a simple led connected at pin 13 on arduino board.
If I can see how this is done in VB then it would be simple to make the rest
 
 
Logged

Debian,Mint,Ubuntu
Arduino Mega 2560
Arduino Nano
Arduino Duemilanove
MAC OS Montain Lion
Raspberry PI Model B


Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi everyone,

I'm having exactly the same problem. I compiled Andrew's code and everything seemed to be fine. However, when I tried to control the PWM pins, nothing happens. I noticed as well that the analog displays are unresponsive. They don't change at all.

I as well took his DLL components and try to build an application from scratch with the same results.

I'd appreciate if anyone you guys could give us a hand with this one?

Thanks in advance.
Logged

Pages: [1]   Go Up
Jump to: