Go Down

Topic: Controlling Remote Controlled Sockets (SC2262 emulation by Arduino) (Read 11 times) previous topic - next topic

celem

CaptainIffy - Thanks for this post. It is very informative. Have you done any work on the receive side of things? My planned project is the opposite of your work - I want to handle the receive side of things. Specifically, I want to use an Arduino to receive 433MHz transmissions from a remote keyfob that uses a SC2262 chip. The specific keyfob that I am going to use costs under $8US and is commonly sold on eBay and included with cheap Chinese alarm systems, also sold on eBay. I have attached a photo of the target keyfob.

aero9

CaptainIffy, thanks! this is very close to what i am working on.

I do not have a "DSO Nano V2" oscilloscope, but i do have a 4333 MHz receiver for the arduino uno, and i was hoping to use that to decode the signal the remote transmits.

I understand it should be possible, but i was trying to determine what rate i should read from the transmitter. I see that you found that using from the 3.3MOhm resistor value.

// SC2262 internal clock is run at 10KHz for "smj" transmitter device (3.3MOhm timing resistor), therefore 100 microSecond wavelength

My SC2262 has a 1MOhm resistor value, i was unsure how you calculated the wavelength from that. Could you please explain that?

Stuart_B

In order to start to ply with this project I've tried to upload the code as is, with the TX unit connected, but i'm getting a verify error on the code, I've looked through it but can't understand why it's having an issue with the array on line 121, error:

sketch_nov22a.ino: In function 'void sendOneSC2262Packet()':
sketch_nov22a:121: error: switch quantity not an integer
sketch_nov22a.ino: In function 'void loop()':
sketch_nov22a:270: error: incompatible types in assignment of 'char' to 'char [13]'.

Is anyone able to point me in the right direction?

Many thanks,
Stuart.

CaptainIffy

aero9 - The frequency/wavelength relationship with the resistor value is in the sc2262 chip specification.

ali12345

#9
Jan 09, 2014, 08:49 pm Last Edit: Jan 09, 2014, 08:50 pm by ali12345 Reason: 1
Nice job. I bought all the same parts a couple of years ago intending to do this but I never got around to implementing it until today.

There's a couple of bugs in the code - a few array indices are missing (that's causing the error Stuart_B reported above), and I replaced the command parser with one that works off a single character. After that it worked fine. It works much better than the actual remote!

Go Up