Pages: [1]   Go Down
Author Topic: Old sketch runs, but modified sketch will not upload  (Read 397 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 31
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I've gone through the troubleshooting guide and am at the point where it says,
"If it still doesn't work, you can ask for help in the forum. Please include the following information:

    * Your operating system.

Ubuntu Linux 10.04 (Lucid Lynx)

    * What kind of board you have.

Arduino Deumilanove

    * Whether or not you were ever able to upload to the board. If so, what were you doing with the board before / when it stopped working, and what software have you recently added or removed from your computer?

The board has worked without problems since March of 2010. I was successfully running a binary counter and was simply modifying the sketch to slow down the main loop by changing a statement from "delay(500);" to "delay(1000)". There were no software changes or system updates between the last time the board worked properly and the time it failed...about five minutes later. When I attempt to upload the modified sketch, the LED on pin 13 blinks one time, the board resets and then continues to run the old sketch. The tx and rx indicators do not light

    * The messages displayed when you try to upload with verbose output enabled.

Binary sketch size: 1058 bytes (of a 30720 byte maximum)
avrdude -v -v -v -v -patmega328p -carduino -P/dev/ttyUSB0 -b57600 -D -Uflash:w:/tmp/build5382427960950924709.tmp/BA17_595BinaryCounter.cpp.hex:i


avrdude: Version 5.10, compiled on Mar 23 2010 at 15:03:00
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "/etc/avrdude.conf"
         User configuration file is "/home/ctdahle/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/ttyUSB0
         Using Programmer              : arduino
         Overriding Baud Rate          : 57600
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: ser_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding

avrdude done.  Thank you.


I tried a serial loop-back test (jumper from RESET to GND and another jumper from Pin0(rx) to Pin1(tx). Data sent from the serial monitor window does not loop back at any speed.
 
I have tried connecting the board to each of the several computers I have previously used to program it and get similar results.

I would be grateful for any and all suggestions. My pace of learning was just starting to accelerate and now I feel like I've hit the wall.
Logged

Lancashire, UK
Offline Offline
Edison Member
*
Karma: 9
Posts: 1991
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Sounds like the bootloader has become corrupted. If it's doing the same trick on multiple computers, it's certainly the Arduino.   
Logged


0
Offline Offline
Newbie
*
Karma: 0
Posts: 31
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Does this mean that I can repair the problem by replacing the chip, or do I need to replace the Arduino...or something else?

Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 31
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Also, is the negative result of the serial loopback test consistent with a corrupted bootloader, or does it indicate a failure of the serial communications hardware on the board?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 31
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I am continuing to try to sort this out. A friend burned the bootloader to a pair of new Atmega328 chips for me...and now I know how to do that.  I tried both new chips in the problematic board. The blink sketch that was preloaded on the chips ran just find, but the Arduino still will not accept new code, returning the same "programmer not responding" error indicated in my initial post. I think this rules out the bootloader as the source of the problem.

I do note that when I attempt to upload my code, the TX and RX indicators all flash as does the Pin13 LED, so there is some kind of communication between my computer and the board.

My gut feeling is that the negative result of my serial loopback test indicates failure of the FTDI USB to serial chip, but I would sure feel better if i had some verification of my ill informed analysis before I give up on this board and buy a new one.
Logged

Pages: [1]   Go Up
Jump to: